Ask Your Question
2

openni_tracker "Find user generator failed"

asked 2012-07-01 08:55:08 -0600

nios gravatar image

updated 2016-10-24 09:02:43 -0600

ngrennan gravatar image

Hi all!

I try to run openni_tracker as follows:

rosrun openni_tracker openni_tracker

after I have launched

roslaunch openni_launch openni.launch

The problem is that when I run the tracker I get an error:

[ERROR] Find user generator failed: This operation is invalid!

Just in case: if I try to run it once more I get no respond and then:

[ERROR] InitFromXml failed: Got a timeout while waiting for a network command to complete!

I believe that "find user" error is generated from the line 150 of the file openni_tracker.cpp in /opt/ros/fuerte/stacks/openni_tracker/src:

149: nRetVal = g_UserGenerator.Create(g_Context);
150: CHECK_RC(nRetVal, "Find user generator");

Which goes to a macro:

#define CHECK_RC(nRetVal, what)                                    \ 
    if (nRetVal != XN_STATUS_OK)                                      \
    {                                                                 \
        ROS_ERROR("%s failed: %s", what, xnGetStatusString(nRetVal)); \
        return nRetVal;                                               \
    }

So g_UserGenerator.Create(g_Context) for some reason returns not XN_STATUS_OK.

Maybe someone had that issue and knows how to resolve it. As you may have noticed I run ros-fuerte. Ubuntu 12.04

PS. I'm still fairly new to ROS, so any suggestions of actions that I can take are welcome :) I tried to change the file openni_tracker.cpp and recompile openni_tracker via rosmake openni_tracker, but that doesn't actually do the trick. Would be gratefull if someone could point me my mistakes. I know that there are a couple of questions that look like this one, but none of those is solved, though it's an important part of ros, I think. Thanks in advance.

UPD: I also experience this error on another ubuntu 12.04 PC in my lab. So it seems like this is fuerte+Ubuntu 12.04 issue. I don't have this error on Ubuntu 10.04 and ros-fuerte.

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
0

answered 2012-12-14 01:44:27 -0600

nios gravatar image

updated 2012-12-14 01:44:48 -0600

I've been able to resolve the issue with this post.

edit flag offensive delete link more
1

answered 2012-07-12 05:04:27 -0600

Install PrimeSense NITE using the following guide.

http://mitchtech.net/ubuntu-kinect-openni-primesense/

PS. I skipped OpenNI and Kinect installation parts.

edit flag offensive delete link more
0

answered 2015-02-12 10:08:54 -0600

I am using ROS Hydro on Ubuntu 12.04 with a Microsoft Kinect. From top to bottom, this is what worked for me:

sudo apt-get install ros-<ros_distro>-openni-camera
sudo apt-get install ros-<ros_distro>-openni-launch
sudo apt-get install ros-<ros_distro>-openni-tracker

Go to this Dropbox from isura (Thanks) and download NITE-Bin-Linux-x64-v1.5.2.23.tar.zip. Extract the zip and tar into a temporary folder (i.e., ~/tmp).

cd ~/tmp/NITE-Bin-Dev-Linux-x64-v1.5.2.23/
sudo ./install.sh

Ensure your Microsoft Kinect is properly connected, then run:

roslaunch openni_launch openni_launch camera:=openni

In a separate terminal window run:

rosrun openni_tracker openni_tracker

In another terminal window run:

rosrun rviz rviz

In Rviz, change Global Options > Fixed Frame to openni_depth_optical_frame.

"Add" the visualization (bottom left) PointCloud2.

Change PointCloud2 >Topic to /openni/depth_registered/points (but whatever you pick works).

"Add" the visualization (bottom left) TF.

Stand in front of the Microsoft Kinect and make the "Psi Pose". Axes should appear on all your joints.

I hope this helps you. There are a lot of different versions of NITE out there and this is the one that happened to work for me.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2012-07-01 08:55:08 -0600

Seen: 5,927 times

Last updated: Feb 12 '15