ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A
Ask Your Question

Why does the algorithm of the multi lidar calibrator package of autoware not converge, if an ouster lidar and a velodyne lidar is in usage?

asked 2021-04-09 15:04:07 -0500

linbic gravatar image

I try to transform an ouster lidar together with a velodyne lidar with the multi lidar calibrator package of autoware. So I set the topic of the ouster as the parent point cloud, and the topic of the velodyne as the child point cloud. I also tried it the opposite way. I also provide an initial guess for the transformation. The ouster lidar provides a point cloud with more points than the velodyne, I already tried it with a downsampled version of the ouster, that the point cloud had almost the same size. I know that the Intensity of the point clouds are different, but I am not sure if that's a problem.

I also made a transformation with two velodyne lidars, this works without problems. Has somebody an explanation for this or better an idea how to get the transformation between the ouster and the velodyne work?

edit retag flag offensive close merge delete


@TakaHoribe Are you able to answer this or can you recommend someone from TierIV who could help?

Josh Whitley gravatar image Josh Whitley  ( 2021-04-14 11:49:41 -0500 )edit

can you please provide more information? - what command are you executing? - the topics are correctly set? - do you see any output in the terminal? - do you see any output in rviz, visualizing the topic? can you share a screenshot?

amc-nu gravatar image amc-nu  ( 2021-04-16 00:41:37 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2021-04-16 04:43:13 -0500

linbic gravatar image

updated 2021-04-17 04:35:17 -0500

I execute following command in a sourced terminal of the autoware package:

rosrun multi_lidar_calibrator multi_lidar_calibrator _points_child_src:=/vlp210/velodyne_points _points_parent_src:=/os_cloud_node/points _x:=0.0 _y:=0.65 _z:=0.0 _roll:=0.01 _pitch:=0.01 _yaw:=1.57079

I am getting following output in the terminal:

[ INFO] [1618564791.395518755]: [multi_lidar_calibrator] points_parent_src: /os_cloud_node/points
[ INFO] [1618564791.399305431]: [multi_lidar_calibrator] points_child_src: /vlp210/velodyne_points
[ INFO] [1618564791.400881924]: [multi_lidar_calibrator] voxel_size: 0.75
[ INFO] [1618564791.402085844]: [multi_lidar_calibrator] ndt_epsilon: 0.01
[ INFO] [1618564791.403269552]: [multi_lidar_calibrator] ndt_step_size: 0.10
[ INFO] [1618564791.404460825]: [multi_lidar_calibrator] ndt_resolution: 1.00
[ INFO] [1618564791.405611919]: [multi_lidar_calibrator] ndt_iterations: 400
[ INFO] [1618564791.414979458]: [multi_lidar_calibrator] Initialization Transform x: 0.00 y: 0.65 z: 0.00 roll: 0.01 pitch: 0.01 yaw: 1.57
[ INFO] [1618564791.418339164]: [multi_lidar_calibrator] Subscribing to... /os_cloud_node/points
[ INFO] [1618564791.421268007]: [multi_lidar_calibrator] Subscribing to... /vlp210/velodyne_points
[ INFO] [1618564791.421880733]: [multi_lidar_calibrator] Publishing PointCloud to... /points_calibrated
[ INFO] [1618564791.421981795]: [multi_lidar_calibrator]cloud synchronizer
[ INFO] [1618564791.422111812]: [multi_lidar_calibrator]register callback
[ INFO] [1618564791.422157368]: [multi_lidar_calibrator] Ready. Waiting for data...
[ WARN] [1618564918.198777044]: Messages of type 1 arrived out of order (will print only once)

In rviz the topic /points_calibrated is empty. In the individual topics /vlp210/velodyne_points and /os_cloud_node/points I can see the pointclouds clearly.

I am working with a bag file which contains all three topics (the two velodyne topics and the osuter topic).

If I run the command from above with the other velodyne (/vlp220/velodyne_points) as the _points_parent_src, I get the transformation matrix between the two pointclouds as an output in the terminal and in rviz both pointclouds are shown in the topic /points_calibrated.

And the ouster lidar is 64 channel and the velodyne a 16 channel.

I am sorry for don't sharing a screenshot, i don't have enough points for that. And the given Information was too long to add only a comment.

edit flag offensive delete link more


According to this message.

Messages of type 1 arrived out of order (will print only once)

Can you check if both point clouds have the correct timestamp? probably header time is incorrect.

amc-nu gravatar image amc-nu  ( 2021-04-19 22:15:11 -0500 )edit

That was such a good hint. Thank you very much! The algorithm converged successfully.

linbic gravatar image linbic  ( 2021-04-26 12:32:48 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools


Asked: 2021-04-09 15:04:07 -0500

Seen: 564 times

Last updated: Apr 17 '21