Ask Your Question
0

Joy_node don't publish

asked 2021-03-22 13:22:37 -0500

Thibaut gravatar image

I've just done a fresh install of ros Noetic with Ubuntu mate 20.04 on both a RPi4(Master) and on a Virtual Machine on my computer. My probem append when I run joy_node on the Virtual machine with the Xbox360 plug on it. I've follow the tutorial for the installation and configuration. But nothing is publish on the /joy topic.

Nevertheless I've tested to plug the Xbox controller on the RPi4 and do the same installation and it work (but my goal is to remote control the RPi4) so I don't know what I should have done wrong for the Virtual machine.

Do you have any idea?

edit retag flag offensive close merge delete

Comments

Same issue with ROS2 foxy with Ubuntu 20.04 on RPi4 and PS2 Gamepad. The command "jstest /dev/input/js0" confirm that the gamepad is working well on this RPi4. The same gamepad was ok on the same RPi4 with Ubuntu 18.04 and Melodic. I don't have this issue with ROS2 foxy Ubuntu 20.04 on Intel.

resnault gravatar image resnault  ( 2021-04-01 03:49:31 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2021-03-22 16:47:05 -0500

FedeBO gravatar image

I dont know which is your problem but for my experience i always had some problems with rpi4 with ubuntu and ROS. Maybe is better if u run ros on other OS designed specifically for raspberry like RASPBIAN etc... i had problems with sensors and this fix everything. Hope will help u!

edit flag offensive delete link more

Comments

I think you are right. I just made a test using the Virtual Machine as ROS Master and when I plug the Xbox controller on it, the joy_node works without problem and rostopic echo /joy publishes correctly.

It's weird because I had the same setup a year ago with a raspberry pi 3b+ and a Virtual Machine under Ubuntu mate 18.04 and ROS Melodic which worked perfectly

I'm using Ubuntu Mate on the RPi because when I install Raspbian OS I alway get trouble with installation from source and when it is not installation issues it is problem of dependencies of packages I want to catkin_make.

And the Ubuntu Mate OS on RPi is 64-bits OS (and I think it is better than Raspbian 32-bits OS)

Thibaut gravatar image Thibaut  ( 2021-03-23 05:08:51 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2021-03-22 12:57:28 -0500

Seen: 93 times

Last updated: Mar 22 '21