Ask Your Question
0

ERROR: cannot launch node of type [moveit_ros_move_group/move_group]: moveit_ros_move_group

asked 2021-03-21 21:14:33 -0500

1210652636 gravatar image

When I run the command:

roslaunch ur5_moveit_config ur5_moveit_planning_execution.launch sim:=true

, some errors happened:

ERROR: cannot launch node of type [moveit_ros_move_group/move_group]: moveit_ros_move_group ROS path [0]=/opt/ros/kinetic/share/ros ROS path [1]=/home/xzs/catkin_ws/src ROS path [2]=/opt/ros/kinetic/share

How can I figure it out?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2022-02-03 01:44:38 -0500

Robo_guy gravatar image

updated 2022-02-03 01:47:49 -0500

I had encountered the same problem. The ros-move-group package is missing, it may have got deleted by mistake maybe, you can re-install moveit by doing this - sudo apt install ros-kinetic-moveit so that the ros-move-group as well as any other missing packages will get installed again. Doing this should remove the error and solve your problem. It had worked for me.

edit flag offensive delete link more

Comments

@1210652636 did this solve your problem ?

Robo_guy gravatar image Robo_guy  ( 2022-02-19 05:26:50 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2021-03-21 21:14:33 -0500

Seen: 379 times

Last updated: Feb 03