ROS noetic installation unmet dependencies

asked 2021-02-27 10:37:18 -0600

teshansj gravatar image

I am trying to install ROS noetic on a Ubuntu 20.04 x64 i7 laptop. I have added the source list and GPG keys. But I get an error unmet dependencies when tried to install ros-noetic-desktop-full

$ sudo apt install ros-noetic-desktop-full 

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ros-noetic-desktop-full : Depends: ros-noetic-desktop but it is not going to be installed
                           Depends: ros-noetic-perception but it is not going to be installed
                           Depends: ros-noetic-simulators but it is not going to be installed
                           Depends: ros-noetic-urdf-sim-tutorial but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

When I try to individually install the said dependencies, I still get similar messages. I tried to follow the dependency tree by issuing apt install xxx for dependent packages in these error messages. At the end there is always a dependency saying something like this

sudo apt install libglvnd0
The following packages have unmet dependencies:
 libglx-dev : Depends: libglx0 (= 1.3.1-1) but 1.3.2-1~ubuntu0.20.04.1 is to be installed

xxxx: Depends: yyyy (= X.X.X.X) but X.X.X.X~ubuntu0.20.04.1 is to be installed format is the same for the dependencies at the end of the trail. I can install each of these by specifying the version apt install yyyy=X.X.X.X. But I do not think this is the correct way to go. Can someone please help?

edit retag flag offensive close merge delete


Not sure if it could help but I just had the same issue while upgrading from Ubuntu 18.04 and Melodic to 20.04 and Noetic. I had the same output as you for the install of ros-noetic-desktop. Turned out I did not properly remove every existing packages of melodic; which I thought I did before upgrading Ubuntu versions.. After that the install of noetic desktop worked as usual normally. Maybe that can help someone.

Vincent_V gravatar image Vincent_V  ( 2021-03-01 03:51:53 -0600 )edit

Interesting. Can you both explain your system setups a bit more. Is this a clean install of 20.04 or is did you upgrade from and earlier OS?

kscottz gravatar image kscottz  ( 2021-03-01 13:20:32 -0600 )edit

This is a clean installation. But as I remember, I installed nvidia docker before ROS. Nothing major other than that was in the OS when this happened.

teshansj gravatar image teshansj  ( 2021-04-05 03:35:59 -0600 )edit