Ask Your Question
0

Bumblebee2 package: failed to open device at launch [closed]

asked 2012-06-26 00:28:31 -0600

mazkarate gravatar image

updated 2012-06-26 03:10:55 -0600

joq gravatar image
  • OS: Ubuntu 12.04
  • ROS: Fuerte
  • Camera: Bumblebee2 08S2C
  • Other Software include: Bumblebee2 ROS package, libdc1394-22, Coriander programme.
  • Nice tutorial to set up all this: here

After debugging some errors due to incompatibilities wrt different ROS and Ubuntu releases I have successfully compiled and built the Bumblebee2 package and made the appropriate changes to the original files (explained at the tutorial link) to use it with a BB2 camera.

However when I launch the package with the launch file provided I the following error is returned:


process[bumblebee2-2]: started with pid [3926]

INFO [1340704820.361870429]: Reconfigure request: brightness -1, encoding , exposure -1, gain -1, shutter -1, whitebalance auto

INFO [1340704820.429462335]: [camera] video mode: format7_3, frame ID: /camera

INFO [1340704820.432799768]: Found camera with GUID b09d0100a9bcc0

INFO [1340704820.432915774]: No guid specified, using first camera found, GUID: b09d0100a9bcc0

libdc1394 error: Format_7 Error_flag_1 is set: in _dc1394_v130_handshake (format7.c, line 122): invalid image position, size, color coding or ISO speed

libdc1394 error: Format_7 Error_flag_1 is set: in dc1394_format7_set_roi (format7.c, line 864): Handshaking failed after setting size and position

WARN [1340704820.437645638]: Failed to set format7_3 parameters for Bumblebee2

FATAL [1340704820.446928383]: [camera] exception opening device: [Camera1394::open]: Failed to open device!

Segmentation fault, stopping camera driver.

[bumblebee2-2] process has died [pid 3926, exit code -11, cmd /home/lrm/ros_workspace/bumblebee2/camera_drivers_experimental/camera1394/bin/camera1394 __name:=bumblebee2 __log:=/home/lrm/.ros/log/bcd5b270-bf75-11e1-924d-0024d6730c52/bumblebee2-2.log]. log file: /home/lrm/.ros/log/bcd5b270-bf75-11e1-924d-0024d6730c52/bumblebee2-2*.log


Also if I open the Coriander and try to display the camera output coriander throws an error that says it could not get the ISO status. (??)

Camera works fine, I have tested it in another computer and I can actually see the output using Coriander in that other machine. any ideas?

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2013-12-29 13:53:05

Comments

1

If coriander does not work on that machine, you probably have an IEEE 1394 problem, not a ROS problem. What are the differences with the one that does work? Different bus interface card, maybe?

joq gravatar imagejoq ( 2012-06-26 03:18:47 -0600 )edit
1

I agree with @joq. Also, you really shouldn't have to recompile libdc1394 and coriander from scratch, it's available in apt on Ubuntu. Perhaps you introduced some error through doing that.

mjcarroll gravatar imagemjcarroll ( 2012-06-26 14:56:08 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2012-06-27 02:53:28 -0600

mazkarate gravatar image

Thanks guys, actually I did not recompile libdc1394 as I knew I already got it. I installed Coriander using Ubuntu Software Center (much easier and straightforward than the kind of installation done in that tutorial). What confuses me it is that Coriander recognizes the Bumblebee2 camera when opening it, I mean that if I open Coriander while having the camera connected to the FireWire port Coriander actually recognizes the camera and it can tell the info for the device detected such as the name (Point Grey Research Bumblebee2 BB2-08S2C), the GUID and other specs. I can also go to services tab of the Coriander and set up the format and other options but it is when starting the ISO control to display the camera output that I get that error of "could not get ISO status". Also if I look into the kern.log file when connecting the camera I see a firewire_core message that tells that a device was created with the same GUID that later the Coriander tells (is the same of course). So I don't know what actually could be wrong in there about the IEEE1394...

edit flag offensive delete link more
0

answered 2012-06-27 07:50:03 -0600

mazkarate gravatar image

Ok, Coriander does display the camera output now however, launching the ros bumblebee2 package I still get the same error saying that it fails to open the device. Maybe there is some configuration of the camera that I did wrong?

Any ideas from the error output?

edit flag offensive delete link more

Comments

You need to make sure that you have appropriate permissions to access the hardware without using sudo. I know that this has tripped people up in the past, so it may be worth looking into.

mjcarroll gravatar imagemjcarroll ( 2012-06-28 02:18:40 -0600 )edit

Actually when installing the FlyCap2 software from Point Grey, during the installation a user group called pgrimaging is automatically created (and your user added to that group) with the necessary udev rules to configure this group to have access to all the IEEE1394 and USB devices...

mazkarate gravatar imagemazkarate ( 2012-06-28 05:25:01 -0600 )edit

Question Tools

Stats

Asked: 2012-06-26 00:28:31 -0600

Seen: 904 times

Last updated: Jun 27 '12