ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
1

[ROS2] ros2 doctor: UserWarning: <PKG> has been updated to a new version

asked 2021-02-15 23:54:55 -0500

lmiller gravatar image

updated 2021-02-16 01:13:21 -0500

Hello all,

i had run ros2 doctor on my PC and got following output:

/opt/ros/foxy/lib/python3.8/site-packages/ros2doctor/api/package.py: 112: UserWarning: joint_state_controller has been updated to a new version. local: 0.1.1 < required: 0.2.0
/opt/ros/foxy/lib/python3.8/site-packages/ros2doctor/api/package.py: 112: UserWarning: ament_index_python has been updated to a new version. local: 1.0.1 < required: 1.0.2
/opt/ros/foxy/lib/python3.8/site-packages/ros2doctor/api/package.py: 112: UserWarning: domain_coordinator has been updated to a new version. local: 0.9.0 < required: 0.9.1
/opt/ros/foxy/lib/python3.8/site-packages/ros2doctor/api/package.py: 112: UserWarning: ros2controlcli has been updated to a new version. local: 0.1.2 < required: 0.1.6
/opt/ros/foxy/lib/python3.8/site-packages/ros2doctor/api/package.py: 112: UserWarning: control_msgs has been updated to a new version. local: 2.4.1 < required: 2.5.0
/opt/ros/foxy/lib/python3.8/site-packages/ros2doctor/api/package.py: 112: UserWarning: controller_interface has been updated to a new version. local: 0.1.2 < required: 0.1.6
/opt/ros/foxy/lib/python3.8/site-packages/ros2doctor/api/package.py: 112: UserWarning: hardware_interface has been updated to a new version. local: 0.1.2 < required: 0.1.6
/opt/ros/foxy/lib/python3.8/site-packages/ros2doctor/api/package.py: 112: UserWarning: velocity_controllers has been updated to a new version. local: 0.1.1 < required: 0.2.0
/opt/ros/foxy/lib/python3.8/site-packages/ros2doctor/api/package.py: 112: UserWarning: ament_cmake_ros has been updated to a new version. local: 0.9.0 < required: 0.9.1
/opt/ros/foxy/lib/python3.8/site-packages/ros2doctor/api/package.py: 112: UserWarning: ros2_control has been updated to a new version. local: 0.1.2 < required: 0.1.6
/opt/ros/foxy/lib/python3.8/site-packages/ros2doctor/api/package.py: 112: UserWarning: controller_manager_msgs has been updated to a new version. local: 0.1.2 < required: 0.1.6
/opt/ros/foxy/lib/python3.8/site-packages/ros2doctor/api/package.py: 112: UserWarning: rqt_gui has been updated to a new version. local: 1.0.6 < required: 1.0.7
/opt/ros/foxy/lib/python3.8/site-packages/ros2doctor/api/package.py: 112: UserWarning: diagnostic_updater has been updated to a new version. local: 2.0.4 < required: 2.0.6
/opt/ros/foxy/lib/python3.8/site-packages/ros2doctor/api/package.py: 112: UserWarning: rqt_py_common has been updated to a new version. local: 1.0.6 < required: 1.0.7
/opt/ros/foxy/lib/python3.8/site-packages/ros2doctor/api/package.py: 112: UserWarning: rqt_gui_cpp has been updated to a new version. local: 1.0.6 < required: 1.0.7
/opt/ros/foxy/lib/python3.8/site-packages/ros2doctor/api/package.py: 112: UserWarning: controller_manager has been updated to a new version. local: 0.1.2 < required: 0.1.6
/opt/ros/foxy/lib/python3.8 ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2021-02-17 06:23:10 -0500

lmiller gravatar image

The current versions of the ROS2 packages will sync monthly to the rosdistro Repo. After that a update with apt update can be done.

See the latest sync and status on ROS Discourse

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2021-02-15 23:54:55 -0500

Seen: 492 times

Last updated: Feb 17 '21