ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

ValueError: PyCapsule_GetPointer called with incorrect name

asked 2021-02-12 09:20:19 -0600

anonymous user


I installed ROS noetic for ubuntu 20.04 following the steps presented on the next page:, but the rqt command is not working for me and it always shows the following error

Traceback (most recent call last):
File "/opt/ros/noetic/bin/rqt", line 13, in
File "/opt/ros/noetic/lib/python3/dist-packages/rqt_gui/", line 61, in main
return super(
File "/opt/ros/noetic/lib/python3/dist-packages/qt_gui/", line 407, in main
from python_qt_binding import QT_BINDING
File "/opt/ros/noetic/lib/python3/dist-packages/python_qt_binding/", line 55, in
from .binding_helper import loadUi, QT_BINDING, QT_BINDING_MODULES, QT_BINDING_VERSION # @UnusedImport
File "/opt/ros/noetic/lib/python3/dist-packages/python_qt_binding/", line 274, in
File "/opt/ros/noetic/lib/python3/dist-packages/python_qt_binding/", line 108, in _select_qt_binding
QT_BINDING_VERSION = binding_loader(required_modules, optional_modules)
File "/opt/ros/noetic/lib/python3/dist-packages/python_qt_binding/", line 155, in _load_pyqt
_named_optional_import('PyQt5.%s' % module_name)
File "/opt/ros/noetic/lib/python3/dist-packages/python_qt_binding/", line 142, in _named_optional_import
File "/opt/ros/noetic/lib/python3/dist-packages/python_qt_binding/", line 133, in _named_import
module = builtins.import(name)
ValueError: PyCapsule_GetPointer called with incorrect name
edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2021-02-27 21:18:58 -0600

anonymous user


problem solved by uninstalling PyQt5 and PyQt5-sip with pip3

edit flag offensive delete link more



thanks, It solved also my problem

EPisano gravatar image EPisano  ( 2021-03-26 06:07:51 -0600 )edit

Thank you!

gorkemsavran gravatar image gorkemsavran  ( 2021-10-06 18:12:46 -0600 )edit

I'm curious how this happened. Perhaps you had previously installed PyQt5 and PyQt5-sip with pip3, and then the instructions installed an older version PyQt5 and PyQt5-sip via apt. If this is the case, it might make sense to improve the Noetic install instructions somehow.

clyde gravatar image clyde  ( 2021-12-30 09:11:04 -0600 )edit

Can the Noetic install instructions be improved?

clyde gravatar image clyde  ( 2021-12-30 09:15:16 -0600 )edit

Thank you, this solved my problem too.

pip3 uninstall PyQt5 pip3 uninstall PyQt5-sip

bruttherjoe gravatar image bruttherjoe  ( 2023-08-02 23:02:24 -0600 )edit

answered 2021-04-24 06:03:27 -0600

TheWerner gravatar image

HI all,

great! It should be added that "apt remove python3-pyqt5" does not do the trick. When I do this, it would remove the whole ros installation.

Thanks! Werner

edit flag offensive delete link more

Question Tools



Asked: 2021-02-12 09:20:19 -0600

Seen: 5,944 times

Last updated: Feb 27 '21