Ask Your Question
0

How to avoid obstacles in op_planner

asked 2021-01-14 01:03:51 -0500

Mohsen.ciw gravatar image

I have also this problem that seems the vehicle doesn't detect any obstacle. I am using ubuntu 1.18 ros melodic and Autoware 1.14 (I am also using LGSVL as simulator) @cwhong yes I am using lidar for detection. and I used a ray ground filter for ground removal. it publishes point on /points_no_ground as you said. here is my screen: (yellow line is the road middle)

image description

then I start "lidar_euclidean_cluster_detect with this setting(based on what i read i change the output frame to "map"):

image description

and here is my screen, so far so good!, it detects the obstacle in front of it.:

image description

But the /detection/lidar_detector/objects_markers is on the map frame and in rviz it was shown near the map frame far from the vehicle.

image description

I turn on lidar_kf_contour_track and start op_global_planner:

image description

Then start these nodes in order:

op_common_params op_trajectory_generator then it creates the roll outs:

image description

op_trajectory_evaluator op_behavior_selector pure_pursuit twist_filter the vehicle starts to move but it does not consider the obstacle and it crashes. also what is noticeable is that there is nothing in the topic /tracked_object published by liar_kf_contour_track. basically, the open planner sees nothing!

image description

and also nothing listen to the euclidean cluster!

image description

I appreciate it if you have any idea.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
3

answered 2021-01-14 18:56:14 -0500

I would like to suggest two ways.

First, it is said that no one is listening to the publish topic of lidar_euclidean_cluster_detect, but check if the topic is subscribed correctly in the source code of lidar_kf_contour_track. I changed the topic of sub_cloud_clusters to /detection/lidar_detector/cloud_clusters in the lidar_kf_contour_track source code.

Second, when looking at the rviz screen that is currently running, it seems that the map frame and the world frame are not combined. So make sure the overall tf is aligned. When you run rviz with the world frame, all maps, vehicles, and obstacles must appear to ensure that tf is properly aligned.

I've had the same error as yours. If you check the above two things, you will be able to solve it quickly!

edit flag offensive delete link more

Comments

1

Thank you very much

Mohsen.ciw gravatar image Mohsen.ciw  ( 2021-01-15 02:16:45 -0500 )edit

@cwhong, I am also facing similar issue. could you tell on how to change the topic of sub_cloud_clusters to /detection/lidar_detector/cloud_clusters in the lidar_kf_contour_track source code.

vivekgouravs gravatar image vivekgouravs  ( 2021-06-01 04:50:23 -0500 )edit

Please don't use an answer to leave a comment/ask a question. Please create a new question and reference this one instead

jayess gravatar image jayess  ( 2021-06-01 18:38:47 -0500 )edit
0

answered 2021-01-14 03:14:53 -0500

Mohsen.ciw gravatar image

So far by changing the topic of sub_cloud_clusters to /detection/lidar_detector/cloud_clusters in the lidar_kf_contour_track source code my problem solved and the open planner detects the obstacle. also, it generates the local trajectory based on the obstacles. Thank you very much @cwhong

edit flag offensive delete link more

Comments

That's great! I moved my post to 'Answers'. Thank you. :)

cwhong gravatar image cwhong  ( 2021-01-14 18:57:27 -0500 )edit

can you elaborate on how to do this?

vivekgouravs gravatar image vivekgouravs  ( 2021-06-08 09:48:47 -0500 )edit

Good job! Could you please give more details? I did the same work as @cwhong told, but The trajectories blocked by obstacles are still all green(which means see nothing?). I use the carla as simulator, and 64 channels for my lidar, is the same in LGSVL ? I used lidar_euclidean_cluster_detect, lidar_kf_contour_track(simple tracker), op_global, and 5 op_loccal. Could you upload a tutorial (maybe a video?)? Thank you!

quliang gravatar image quliang  ( 2022-01-18 10:00:34 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

3 followers

Stats

Asked: 2021-01-14 01:03:51 -0500

Seen: 395 times

Last updated: Jun 01 '21