ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A answers.ros.org
Ask Your Question
0

How can I run this Gazebo simulation? The launch file is not seen as a launch file

asked 2020-12-16 21:50:50 -0600

ROSNewbie gravatar image

updated 2022-08-07 09:09:48 -0600

lucasw gravatar image

Firstly I'm really really new to ROS. I need to import this world and get it open in Gazebo for a simulation: (https://github.com/aws-robotics/aws-r...)

but when its time to launch I get the error that the launch file is not a launch file. So I wondered if I did the wrong steps before I can launch. I'm using ROS development studio for the terminal and Gazebo. So I tried with another project my co-worker sent me and it worked, here are the steps I took: 1. git clone the project into simulation_ws src 2. then go back to simulation_ws and enter "catkin_make" 3. then I enter "source devel/setup.bash" 4. then i enter roslaunch "file name" "launch file name" 5. Open Gazebo window where robot shows up

but this doesn't work with the project in the link above, so I must be missing something in the steps I took since I'm such a newbie. On the readme it says to include some code in the launch file but when you check one of them the line is already there so I've no idea what that means.

What do you all think?

*edit here is my input commands:

cd simulation_ws

cd src

git clone https://github.com/aws-robotics/aws-robomaker-hospital-world.git

cd ..

catkin_make

source devel.setup.bash

roslaunch aws-robomaker-hospital-world hospital.launch

the terminal output is:

RLException: [hospital.launch] is neither a launch file in package [aws-robomaker-hospital-world] nor is [aws-robomaker-hospital-world] a launch file name The traceback for the exception was written to the log file
edit retag flag offensive close merge delete

Comments

Can you post the exact commands and error? Please, use the 101010 button to format code and terminal input/output.

tryan gravatar image tryan  ( 2020-12-17 08:59:53 -0600 )edit

Hello tryan, I edited the post with the details you requested. Hope this helps. thanks.

ROSNewbie gravatar image ROSNewbie  ( 2020-12-17 09:27:58 -0600 )edit

I'm assuming devel.setup.bash was a typo and in reality you ran source devel/setup.bash, right?

chfritz gravatar image chfritz  ( 2020-12-17 15:38:30 -0600 )edit

you're right chifritz, thanks

ROSNewbie gravatar image ROSNewbie  ( 2020-12-17 20:41:48 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2020-12-17 15:40:44 -0600

updated 2020-12-17 15:41:21 -0600

The name of that package is different from its folder name, as can be seen using rospack:

> rospack list | grep aws
aws_robomaker_hospital_world /home/cfritz/work/lumin/software/catkin/src/aws-robomaker-hospital-world

So you need to run:

source devel/setup.bash
roslaunch aws_robomaker_hospital_world hospital.launch
edit flag offensive delete link more

Comments

@ROSNewbie, note the underscores in place of the dashes in the package name. While some places (GitHub, apt repositories, etc.) use the dash convention, ROS package names follow the underscore convention. As cfritz pointed out, the ROS package name isn't always the same as its folder's name, but you can find it in its package.xml file when in doubt.

tryan gravatar image tryan  ( 2020-12-17 17:00:56 -0600 )edit

@chfritz thanks for the answer it solved the issue.

ROSNewbie gravatar image ROSNewbie  ( 2020-12-17 20:42:37 -0600 )edit
1

@tyan thanks for the help.

ROSNewbie gravatar image ROSNewbie  ( 2020-12-17 20:42:58 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2020-12-16 21:50:50 -0600

Seen: 781 times

Last updated: Dec 17 '20