ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

How to install a stack and package manually in Fuerte?

asked 2012-06-18 22:17:26 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.


I'm trying to install the rosbridge package from the brown_remotelab stack. The tutorials and answers that I've found on the web give more-or-less the following procedure for doing this:

# Enter directory where my stacks are kept
# Checkout repository
svn co
# Enter directory of package
cd brown_remotelab/rosbridge
# Build package and it's dependencies
rosmake --rosdep-install

This doesn't work for me. For starters when I try to run rosmake --rosdep-install I get the error message:

rosmake: error: no such option: --rosdep-install

So it looks like the --rosdep-install option is deprecated. Also if I try running without that option I get:

[ rosmake ] rosmake starting...
[ rosmake ] No package or stack specified.  And current directory 'rosbridge' is not a package name or stack name.
[ rosmake ] Packages requested are: []
[ rosmake ] Logging to directory /root/.ros/rosmake/rosmake_output-20120619-160854
[ rosmake ] Expanded args [] to:
[ rosmake ] ERROR: No arguments could be parsed into valid package or stack names.

Similarly, if I try to use roscd, rospackage or rosstack on the newly downloaded stack and packages I get errors like

roscd: No such package/stack 'rosbridge'


[rosstack] Error: stack/package brown_remotelab not found

So it looks like ROS doesn't know where to find them. This is after re-sourcing my setup.bash.

In short: What is the complete procedure for downloading and installing a ROS stack and package from source in ROS Fuerte?

edit retag flag offensive close merge delete


In my opinion, you should first "roscreate-pkg" with the corresponding name and then svn checkout in this folder. This way the package will be known by ros and rosmake can work (not tested on fuerte).

Erwan R. gravatar image Erwan R.  ( 2012-06-18 23:33:02 -0500 )edit

You only call roscreate-pkg when you really want to create a new package, not when you check something out. It wouldn't help anyway since it seems like the checkout was simply not in the ROS_PACKAGE_PATH.

Lorenz gravatar image Lorenz  ( 2012-06-18 23:35:10 -0500 )edit

Ok, right, thanks for bringing some light on that.

Erwan R. gravatar image Erwan R.  ( 2012-06-19 03:47:06 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2012-06-18 23:31:20 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

You didn't put the checkout into your ros workspace. The cleanest way of managing your workspace is probably by using rosws. You can install it with

sudo apt-get install python-pip
sudo pip install -U rosinstall

Now you can set up a ros workspace:

rosws init ~/ros_workspace /opt/ros/fuerte

Now source the newly generated setup.bash:

source ~/ros_workspace/setup.bash

You can also replace the line source /opt/ros/fuerte/setup.bash by the line above to always use your workspace. Just don't forget to remove setting of the variable ROS_WORKSPACE if you do so in your .bashrc since that is done by rosws' setup.bash.

Now add the repository you want to check out:

rosws set brown_remotelab "" --svn
rosws update brown_remotelab

Source ~/ros_workspace/setup.bash again or open a new terminal to make sure that your ROS_PACKAGE_PATH is updated and try running

rosmake brown_remotelab

rosmake --rosdep-install is not supported in Fuerte anymore. See this question.

edit flag offensive delete link more

answered 2012-08-15 05:34:51 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

using rosdep update solve the problem for me.

edit flag offensive delete link more

Question Tools


Asked: 2012-06-18 22:17:26 -0500

Seen: 6,715 times

Last updated: Aug 15 '12