Failed ROS Melodic Installation on Ubuntu 18.04. Weird dependency issues.

asked 2020-12-14 23:29:52 -0600

AlexSun gravatar image

updated 2020-12-15 09:40:28 -0600

I tried to install ROS Melodic using aptitude on my Ubuntu 18.04 machine. However, the following weird dependency issues happen:

The following packages have unmet dependencies:
 libjpeg-turbo8-dev : Depends: libjpeg-turbo8 (= 1.5.2-0ubuntu5) but 1.5.2-0ubuntu5.18.04.4 is installed
 libldap2-dev : Depends: libldap-2.4-2 (= 2.4.45+dfsg-1ubuntu1) but 2.4.45+dfsg-1ubuntu1.6 is installed
 libgpgme-dev : Depends: libgpgme11 (= 1.10.0-1ubuntu1) but 1.10.0-1ubuntu2 is installed
 libopenexr-dev : Depends: libopenexr22 (= 2.2.0-11.1ubuntu1) but 2.2.0-11.1ubuntu1.3 is installed
 libpng-dev : Depends: libpng16-16 (= 1.6.34-1) but 1.6.34-1ubuntu0.18.04.2 is installed
 libmount1 : Breaks: libmount1:i386 (!= 2.31.1-0.4ubuntu3.6) but 2.31.1-0.4ubuntu3 is to be installed
 libmount1:i386 : Breaks: libmount1 (!= 2.31.1-0.4ubuntu3) but 2.31.1-0.4ubuntu3.6 is installed
 gcc-8-base : Breaks: gcc-8-base:i386 (!= 8.4.0-1ubuntu1~18.04) but 8-20180414-1ubuntu2 is to be installed
 gcc-8-base:i386 : Breaks: gcc-8-base (!= 8-20180414-1ubuntu2) but 8.4.0-1ubuntu1~18.04 is installed
 libelf1 : Breaks: libelf1:i386 (!= 0.170-0.4ubuntu0.1) but 0.170-0.4 is to be installed
 libelf1:i386 : Breaks: libelf1 (!= 0.170-0.4) but 0.170-0.4ubuntu0.1 is installed
 libc6 : Breaks: libc6:i386 (!= 2.27-3ubuntu1.2) but 2.27-3ubuntu1 is to be installed
 libc6:i386 : Breaks: libc6 (!= 2.27-3ubuntu1) but 2.27-3ubuntu1.2 is installed
 libbz2-dev : Depends: libbz2-1.0 (= 1.0.6-8.1) but 1.0.6-8.1ubuntu0.2 is installed
 libtiff5-dev : Depends: libtiff5 (= 4.0.9-5) but 4.0.9-5ubuntu0.3 is installed
 libgcc1 : Breaks: libgcc1:i386 (!= 1:8.4.0-1ubuntu1~18.04) but 1:8-20180414-1ubuntu2 is to be installed
 libgcc1:i386 : Breaks: libgcc1 (!= 1:8-20180414-1ubuntu2) but 1:8.4.0-1ubuntu1~18.04 is installed
 libblkid1 : Breaks: libblkid1:i386 (!= 2.31.1-0.4ubuntu3.6) but 2.31.1-0.4ubuntu3 is to be installed
 libblkid1:i386 : Breaks: libblkid1 (!= 2.31.1-0.4ubuntu3) but 2.31.1-0.4ubuntu3.6 is installed
 libgfortran4 : Depends: gcc-7-base (= 7.3.0-16ubuntu3) but 7.5.0-3ubuntu1~18.04 is installed
 libcurl4-openssl-dev : Depends: libcurl4 (= 7.58.0-2ubuntu3) but 7.58.0-2ubuntu3.10 is installed
 libuuid1 : Breaks: libuuid1:i386 (!= 2.31.1-0.4ubuntu3.6) but 2.31.1-0.4ubuntu3 is to be installed
 libuuid1:i386 : Breaks: libuuid1 (!= 2.31.1-0.4ubuntu3) but 2.31.1-0.4ubuntu3.6 is installed
 libglib2.0-bin : Conflicts: libglib2.0-bin:i386 but 2.56.1-2ubuntu1 is to be installed
 libglib2.0-bin:i386 : Conflicts: libglib2.0-bin but 2.56.4-0ubuntu0.18.04.6 is installed
 libglib2.0-dev : Depends: libglib2.0-0 (= 2.56.1-2ubuntu1) but 2.56.4-0ubuntu0.18.04.6 is installed
 uuid-dev : Depends: libuuid1 (= 2.31.1-0.4ubuntu3) but 2.31.1-0.4ubuntu3.6 is installed
 libicu-dev : Depends: libicu60 (= 60.2-3ubuntu3) but 60.2-3ubuntu3.1 is installed
 libpng-tools : Depends: libpng16-16 (= 1.6.34-1) but 1.6.34-1ubuntu0.18.04.2 is installed
 libexif-dev : Depends: libexif12 (= 0.6.21-4) but 0.6.21-4ubuntu0.5 is installed
 libglib2.0-0 : Breaks: libglib2.0-0:i386 (!= 2.56.4-0ubuntu0.18.04.6) but 2.56.1-2ubuntu1 is to be installed
 libglib2.0-0:i386 : Breaks: libglib2.0-0 ...
(more)
edit retag flag offensive close merge delete

Comments

ARM64? well that sounds like you have the wrong apt sources enabled. Can you please post the result of uname -a and cat /etc/apt/sources.list.d/ros*?

chfritz gravatar image chfritz  ( 2020-12-15 10:17:08 -0600 )edit