Ask Your Question
0

catkin_make Cmake multiple errors

asked 2020-11-29 06:23:51 -0500

j-ub gravatar image

updated 2020-11-30 06:16:21 -0500

Hi there. I have the following erros when i try to do catkin_make. I'm a nob so I will be deeply glad with any help. I have been trying to figure it out by internet info with no results. The problem maybe related with this one "https://answers.ros.org/question/1237..." but the solution in there it's not working for me..

Before I have been using catkin_make and all ROS stuff without a single problem and the problem just appeared from "the nothing".

I do have listed the buildtool dependency in the package.xml file. I have added the source lines in the .bashrc:

source /opt/ros/kinetic/setup.bash source catkin_ws/devel/setup.bash

All is setted up correctly i think. In fact nothing was happening before, all was correctly working for me.

I'm running ROS Kinetic distro in Ubuntu 16.04

Thanks in advance, this is the output when i do catkin_make in catkin_ws directory:

PS.: I have just realised by writing this post than the problem maybe appeared when i was trying to make another catkin_make in a different folder than catkin_ws. I created another folder in $HOME then I created a package (with catkin_create_pkg... etc) and the problem appeared when I tried to do catkin_make in the new folder.

Later on I tried to make a new package in the catking_ws folder (just to check if the problem was It wasn't possible to do a catking_make in another folder than catkin_ws) but no catkin_make possible. The errors are the same always I'm trying to do catkin_make...

PS1.: Also saying I have tried to unnistall catkin but it looks like there is no catkin installed anymore when it is actually installed.

Base path: /home/juanan/catkin_ws
Source space: /home/juanan/catkin_ws/src
Build space: /home/juanan/catkin_ws/build
Devel space: /home/juanan/catkin_ws/devel
Install space: /home/juanan/catkin_ws/install
####
#### Running command: "cmake /home/juanan/catkin_ws/src -DCATKIN_DEVEL_PREFIX=/home/juanan/catkin_ws/devel -DCMAKE_INSTALL_PREFIX=/home/juanan/catkin_ws/install -G Unix Makefiles" in "/home/juanan/catkin_ws/build"
####
-- Using CATKIN_DEVEL_PREFIX: /home/juanan/catkin_ws/devel
-- Using CMAKE_PREFIX_PATH: /home/juanan/catkin_ws/devel;/opt/ros/kinetic
-- This workspace overlays: /home/juanan/catkin_ws/devel;/opt/ros/kinetic
-- Found PythonInterp: /usr/bin/python2 (found suitable version "2.7.12", minimum required is "2") 
-- Using PYTHON_EXECUTABLE: /usr/bin/python2
-- Using Debian Python package layout
-- Using empy: /usr/bin/empy
-- Using CATKIN_ENABLE_TESTING: ON
-- Call enable_testing()
-- Using CATKIN_TEST_RESULTS_DIR: /home/juanan/catkin_ws/build/test_results
-- Found gtest sources under '/usr/src/gmock': gtests will be built
-- Found gmock sources under '/usr/src/gmock': gmock will be built
-- Found PythonInterp: /usr/bin/python2 (found version "2.7.12") 
-- Using Python nosetests: /usr/bin/nosetests-2.7
-- catkin 0.7.29
-- BUILD_SHARED_LIBS is on
-- BUILD_SHARED_LIBS is on

-- ~~  traversing 3 packages in topological order:
-- ~~  - beginner_tutorials
-- ~~  - geek_gasteiz
-- ~~  - juanan_test
-- ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-- +++ processing catkin package: 'beginner_tutorials'
-- ==> add_subdirectory(beginner_tutorials)
-- +++ processing catkin package: 'geek_gasteiz'
-- ==> add_subdirectory(geek_gasteiz)
-- Using these message generators: gencpp;geneus;genlisp;gennodejs;genpy
-- geek_gasteiz: 1 messages, 1 services
-- +++ processing catkin package ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-11-29 09:23:53 -0500

j-ub gravatar image

updated 2020-11-30 06:15:05 -0500

Hi guys! thanks for the help. I founded a solution tho. I simply restored the catkin_package.cmake, catking_package_xml.cmake and toplevel.cmake files in /opt/ros/kinetic/share/catkin/cmake folder.

I got the files from here "https://github.com/ros/catkin/tree/ki..."

Greetings!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2020-11-27 14:30:34 -0500

Seen: 85 times

Last updated: Nov 30 '20