WARNING: ROS_MASTER_URI [] host is not set to this machine

asked 2020-11-17 07:22:13 -0500

Alicorn gravatar image

My ROS_MASTER_URI has been working for the last few days, but for some reason today, it just won't connect to my Master anymore. I'm running ubuntu on a VM to another ubuntu machine, which is connected to a turtlebot - I've tried almost everything I could find on the internet

I've set it up like this On my ubuntu machine, where I want my master



and on my VM



My connection is also bridged, so that's not it - I've also put it into my ~/.bashrc - And I can ping fine between the two machines.

For some reason tho, When I start a roscore on my ubuntu machine (where the Master is on) it says "auto-starting new master" instead of just starting the master on the ROS_MASTER_URI I've set

edit retag flag offensive close merge delete


See this question. It may have something to do with hostname resolution, but I am a little bit out of my comfort zone. Good luck!

JackB gravatar image JackB  ( 2020-11-17 13:22:44 -0500 )edit