Ask Your Question
0

rviz cannot display rrbot properly

asked 2020-11-12 01:40:40 -0500

shiraz_baig gravatar image

I am using unbuntu 18.04 and installed melodic ros distrubition (1.14.9). I have installed catkin tools and use "catkin build" to build my packages. I tried to display rrbot in rviz but it does not display properly. Here are the steps I followed using this tutorial "http://gazebosim.org/tutorials/?tut=r..." a. git cloned rrbot package in ~/catkin_ws/src folder $ git clone https://github.com/ros-simulation/gaz... b. Built the package $ catkin build All the packages (contained in gazebo_ros_demos) were built without errors. c. I launched the rrbot $ source ~/.bashrc (for setup.bash) $ roslaunch rrbot_description rrbot_rviz.launch

It runs without errors with only following warning. The problem is that it does not display rrbot properly. Moreover joint_state_publisher does not move the joints (the joints are not visible what will they move :-) ) BTW when I go on with remaining part of tutorial, it performs correctly in gazebo (gazebo-9)

I kept searching for solution, I wonder, why no one else has faced this problem.

I get a picture which shows a camera window and a whitish stick

The solutions that I have tried: a. resinstalled rviz b. reinstalled robot_state_publisher c. export KINETIC1=1 and then launched the robot d. On another computer installed ros kinetic. And repeated the process. The rrbot correctly display and joint_state_publisher successfully moves the joints.

please tell me how I can correct this problem and how can I move its joints with joint_state_publisher.

edit retag flag offensive close merge delete

Comments

"On another computer installed ros kinetic. And repeated the process. The rrbot correctly display and joint_state_publisher successfully moves the joints"

It means there is definitely something wrong with the setup you are trying to run on the first system you tried. Maybe some installation files are messed up. Send me the package files and I might have a look at them when I get some time.

ZainMehdi gravatar image ZainMehdi  ( 2020-11-16 01:12:32 -0500 )edit

@ZainMehdi, Thanks for your response. I have been able to resolve my problem, I do not know how. :-) . My model is displaying correctly now. I do not know, how :-). Today morning, again it was malfunctioning. I did not do any configuration changes, except closing an old roscore_running terminal. But my model displays, now, correctly in melodic also.

shiraz_baig gravatar image shiraz_baig  ( 2020-11-18 23:03:17 -0500 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2020-11-18 22:36:53 -0500

shiraz_baig gravatar image

I am able to display the model and move the joints correctly with the same command as given above.
     $ roslaunch rrbot_description rrbot_rviz.launch
So, I thought the problem is resolved. But Today, in the morning, I was again facing same problem. I tried to diagnose what is the problem that has again occurred.
The only thing that I found was a "roscore" running from last 1-2 days. I mean, it was running already and I did my roslaunch in another terminal. I am not sure if this is the problem. I tried to duplicate the problem, by running roscore in one terminal and launching above launch file in another terminal. But I could not duplicate my problem. Probably roscore was too fresh and had not malfunctioned as yet.

Anyway, I am not sure what was the reason why, sometimes I can not display it properly. However, at least one thing I am sure now, that whatever it was, it was with my computer and the above launch file correctly displays the model. Thanks for all the help.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2020-11-12 01:40:40 -0500

Seen: 100 times

Last updated: Nov 18 '20