Ask Your Question
0

Git cloned a ros project need help with launching [closed]

asked 2020-10-06 18:59:27 -0500

PGTKing gravatar image

updated 2020-10-07 04:31:21 -0500

gvdhoorn gravatar image

Hi, ros newbie here,

I am using ubuntu 20.04 ros noetic

I git cloned this ros project and tried to run the

roslaunch my_moving_cube_description spawn_moving_cube.launch

in the terminal but am getting the error

RLException: [spawn_moving_cube.launch] is neither a launch file in package [my_moving_cube_description] nor is [my_moving_cube_description] a launch file name
The traceback for the exception was written to the log file

I also did source /opt/ros/noetic/setup.bash beforehand.

Please let me know if you have a fix for this problem.

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by gvdhoorn
close date 2020-10-07 04:30:51.970048

Comments

Please see #q252478 for an example workflow which lets you build packages from source. It's ROS version agnostic, so should also work for Noetic.

It won't help solve incompatibilities between the packages you cloned and Noetic of course. It only takes care of the build process.

gvdhoorn gravatar image gvdhoorn  ( 2020-10-07 04:29:26 -0500 )edit
1

As this is no different from any of the other Q&As on this site about building packages from source, I'm going to close this as a duplicate -- even though @Procópio was kind enough to already start answering.

Please try to use Google and search for existing Q&As before posting your own. Append site:answers.ros.org to your query.

gvdhoorn gravatar image gvdhoorn  ( 2020-10-07 04:30:47 -0500 )edit

@gvdhoorn, I am having issues following your answer on #q252478 as rosdep command doesn't exist in ros noetic

PGTKing gravatar image PGTKing  ( 2020-10-13 15:28:04 -0500 )edit

It certainly does, but you'll have to make sure you'e installed it.

sudo apt install python3-rosdep.

gvdhoorn gravatar image gvdhoorn  ( 2020-10-14 03:44:50 -0500 )edit

followed your @gvdhoorn guidelines to a t including the rosdep sections but roslaunch is still not running. I plan on using the rrbot framework and just substituting files from the other project into the rrbot one, which runs. I not sure if your guidelines work for ros noetic.

PGTKing gravatar image PGTKing  ( 2020-10-14 14:43:54 -0500 )edit

Nothing has changed in Noetic which would affect this.

What could be the case though is that the packages you're trying to build and use don't declare their dependencies correctly.

And just to make sure: you do source /path/to/your/catkin_ws/devel/setup.bashbefore trying to run roslaunch, correct/

gvdhoorn gravatar image gvdhoorn  ( 2020-10-14 14:46:14 -0500 )edit

@gvdhoorn yes, including source before. this (git clone https://bitbucket.org/theconstructcor...) is the git clone if you want to check it out yourself. I am trying to learn ros with openai if you have any alternative projects I can learn from please let me know.

PGTKing gravatar image PGTKing  ( 2020-10-14 15:35:50 -0500 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2020-10-07 03:54:36 -0500

Procópio gravatar image

As you do not mention anything more than cloning, these questions come to my mind:

Have you created a workspace where you then cloned the repository?

Did you compiled it?

Did you sourced your new workspace?

edit flag offensive delete link more

Question Tools

Stats

Asked: 2020-10-06 18:59:27 -0500

Seen: 199 times

Last updated: Oct 07 '20