Ask Your Question
0

(sub)sample point cloud images rviz

asked 2012-06-11 21:51:29 -0500

Brioche gravatar image

updated 2016-10-24 09:02:46 -0500

ngrennan gravatar image

Hi all,

I'm trying to do a simple GUI with Rviz and my kinect, I uncommented the line to use Rviz in kinect+rgbdslam.launch file:

<node pkg="rviz" type="rviz" name="rviz" args="-d $(find rgbdslam)/launch/rviz_config.vcg" respawn="false" output="log" > </node>

I was "playing" with the configuration of Rviz and when I tried to add a pointscloud2 image (like enable Blue or White Display in rviz_config.vcg), but my Rviz application is freezing and I have to kill it because I cant do anything more.

I think it's because /camera/rgb/points or /camera/depth/points are sending too much datas and that's why I would like to subsampling it, by taking one image on two or even more. Does that it make sens to anyone? and is there a tutorial about rviz_config file?

Thanks for your help, I didn't find anything on this subject.

Cheers

Brioche

PS: I'm using electric on ubuntu 11.04.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2012-06-12 07:45:35 -0500

In addition to throttling the topic as @Felix Endres suggested, you could use a VoxelGrid filter to reduce the number of points in each message.

edit flag offensive delete link more

Comments

I'm new in ros, so I don't understand what should I do to reduce the number of points by using VoxelGrid filter. but anyway thanks for the help

Brioche gravatar image Brioche  ( 2012-06-12 21:37:01 -0500 )edit

There's a tutorial that gives an example of using a VoxelGrid for downsampling: http://www.ros.org/wiki/pcl_ros/Tutorials/VoxelGrid%20filtering

Dan Lazewatsky gravatar image Dan Lazewatsky  ( 2012-06-13 03:45:40 -0500 )edit

Thanks a lot, it's almost working perfectly. I'm now going to try to use octo_server.

Brioche gravatar image Brioche  ( 2012-06-13 20:53:08 -0500 )edit
0

answered 2012-06-12 06:05:00 -0500

Have a look at throttle in the topic_tools package. This lets you downscale the data rate of a topic (e.g. the clouds).

Also you could set the openni driver to QVGA resolution via dynamic_reconfigure, which will reduce the size of the clouds to a fourth.

edit flag offensive delete link more

Comments

Thanks Felix. I've been able to reduce the data rate (by using throttle and rostopic bw to confirm reduction) but my rviz application is still freezing. but by setting in QVGA is a bit better but still lagging...Thanks for your help

Brioche gravatar image Brioche  ( 2012-06-12 18:41:51 -0500 )edit

First of all, check that you have hardware accelerated 3D graphics. In rviz, setting the PointCloud option "style" to "points" will speedup rendering a bit. The decay time should be zero.

Felix Endres gravatar image Felix Endres  ( 2012-06-12 22:20:00 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-06-11 21:51:29 -0500

Seen: 999 times

Last updated: Jun 12 '12