Can't invoke catkin workspace, command not found

asked 2020-09-26 12:23:54 -0600

Sassberry184 gravatar image

Hi all, I am trying to install ROS on Raspbian Buster OS, but am having an issue. I have been following instructions found here:

The set up has, until this point, been flawless and quite easy. I followed all the steps but have been unable to invoke the catkin workspace, which is part of step 3.3 in the above mentioned instructions. Running this command:

sudo ./src/catkin/bin/catkin_make_isolated --install -DCMAKE_BUILD_TYPE=Release --install-space /opt/ros/melodic

I am met with a return saying this:

sudo ./src/catkin/bin/catkin_make_isolated: command not found

I initially ran this command before returning to the home directory, which a mechanical engineer friend had directed me to do, noting this in case it may have caused an issue. Running it while in the home directory gives me the same "command not found" error. I also have heard that with older Raspberry Pi models, it is best to decrease the compilation thread count with a -j1 or -j2 option, though it still results in the same error.

I also attempted the command again, minus the DCMAKE part and everything after that, and the same issue still occurs. Please help me to understand what is going on here and why, I am very much a newbie.

Also, when I ran the command before going to the home directory, it gave a very different error. Not sure if this is relevant, but I have the return from that still, in case it is needed.

edit retag flag offensive close merge delete


Hi, I am also getting the same problem. i created one package to write my publisher and subscriber node. But I am unable to build the newly created package. While trying the command : sudo ./src/catkin/bin/catkin_make_isolated --install -DCMAKE_BUILD_TYPE=Release --install-space /opt/ros/melodic

i am getting the same error.

AncientLord gravatar image AncientLord  ( 2020-09-29 01:59:36 -0600 )edit

Hello, I got the solution. You have to be in catkin workspace (if you followed ROS guideline for Raspberry pi, it should be ~/ros_catkin_ws) then invoke the build command.

AncientLord gravatar image AncientLord  ( 2020-09-29 02:03:32 -0600 )edit