Ask Your Question
0

map does not update with respect to base_link

asked 2020-09-24 08:47:20 -0500

Gourav gravatar image

updated 2020-09-24 11:41:49 -0500

Hello guys, can someone tell me why the map is not updating with respect to the displacement in base_link? The map keeps building at one place, whereas I can see the laser data moving wrt base_link, but the map doesn't move.

1) launched the laser scan

2) static tf between map and odom(slam is supposed to provide this, but I always get map frame not available)

3)Odom publisher

4)static tf between base_link and camera_link

5)then I launch the slam_gmapping.

https://drive.google.com/drive/folder...

edit retag flag offensive close merge delete

Comments

Can you please add the pdf output of rosrun tf view_frames to that folder?

JackB gravatar image JackB  ( 2020-09-24 11:19:40 -0500 )edit

done.. I included that

Gourav gravatar image Gourav  ( 2020-09-24 11:27:28 -0500 )edit

Thanks for doing that!

JackB gravatar image JackB  ( 2020-09-24 11:53:05 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2020-09-24 11:52:24 -0500

JackB gravatar image

A big red flag is that your map->odom transform is static. That is almost certainly the reason for the problem behavior. slam_gmapping is responsible for producing that. For some reason I don't understand, you said that you override the map->odom tf with a static transfrom publisher. Remove that and let gmapping publish the map->odom tf and then we should be on our way to fixing the problem.

edit flag offensive delete link more

Comments

I agree with you, but I keep getting this error (https://answers.ros.org/question/3616...) if I don't do the map->odom static transform... I will try once more and will update. thanks for the reply :-)

Gourav gravatar image Gourav  ( 2020-09-24 11:55:50 -0500 )edit

Add a copy of rosrun tf view_frames pdf output without the static map->odom publisher please. Make sure gmapping is running.

JackB gravatar image JackB  ( 2020-09-24 11:58:56 -0500 )edit

Updated the file again.

Gourav gravatar image Gourav  ( 2020-09-24 12:04:40 -0500 )edit

its the same problem, btw I used the following files https://github.com/ros-perception/sla...

Gourav gravatar image Gourav  ( 2020-09-24 12:05:55 -0500 )edit

And when you rostopic echo /your/laser/scan/topic what is the frame_id in the header?

JackB gravatar image JackB  ( 2020-09-24 12:13:45 -0500 )edit

camera_depth_frame

Gourav gravatar image Gourav  ( 2020-09-24 12:16:17 -0500 )edit

And is this all in simulation on the same computer?

JackB gravatar image JackB  ( 2020-09-24 12:21:37 -0500 )edit

yes it is.

Gourav gravatar image Gourav  ( 2020-09-24 12:23:19 -0500 )edit
0

answered 2020-09-25 04:57:57 -0500

Gourav gravatar image

updated 2020-09-26 10:21:57 -0500

Now the slam is giving the transform from map -> odom, as I removed( param name="use_sim_time" value="true"/) line from slam_gmapping.launch.

edit flag offensive delete link more

Comments

Ask another more well thought out question, do not post another questions as an answer to a question you previously asked. This is ROS Answers, not ROS Message Board :)

JackB gravatar image JackB  ( 2020-09-26 10:15:45 -0500 )edit

my bad..:-) new to this environment.. will edit my answer.

Gourav gravatar image Gourav  ( 2020-09-26 10:21:13 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2020-09-24 08:47:20 -0500

Seen: 103 times

Last updated: Sep 26