FlyCapture2::ErrorType 33 Error starting isochronous stream.

asked 2020-09-04 17:45:46 -0500

evdo gravatar image

updated 2020-09-04 17:47:18 -0500

Hello guys, I'm using the Pointgray package with a bumblebee2 03s2c camera and Lubuntu 18.04 . My goal is to subscribe two rectified images from different topics

The first command in the terminal is:

 roslaunch pointgrey_camera_driver stereo.launch

after i'm running this script

#!/usr/bin/env python
import rospy
from sensor_msgs.msg import Image
import cv2, cv_bridge 
import numpy as np
import message_filters
import time

bridge=cv_bridge.CvBridge()

def callback(image_right, image_left):
    rospy.loginfo("i'm in")
    left_img = bridge.imgmsg_to_cv2(image_right,desired_encoding='bgr8')
    right_img=bridge.imgmsg_to_cv2(image_left,desired_encoding='bgr8')
    images = np.hstack((left_img,right_img))

    cv2.imshow("window", left_img)
    cv2.waitKey(3)

rospy.init_node('follower')

image_right= message_filters.Subscriber('camera/right/image_rect',Image)
image_left = message_filters.Subscriber('camera/left/image_rect',Image)

ts = message_filters.ApproximateTimeSynchronizer([image_right,image_left,],1,1)
ts.registerCallback(callback)
rospy.spin()

and I'm facing this error

[ERROR] [1596740075.656243330]: Failed to start with error: PointGreyCamera::start Failed to start capture | FlyCapture2::ErrorType 33 Error starting isochronous stream.
[ WARN] [1596740076.653149232]: PointGreyCamera: Failed to retrieve buffer within timeout.

When i subscribe in only one rectified image topic then the script is working flawlessly. I tried

sudo sh -c 'echo 1024 > /sys/module/usbcore/parameters/usbfs_memory_mb'

, but nothing worked . What do you suggest me to do in order to overcome this problem? Thank you in advance!

edit retag flag offensive close merge delete