Ask Your Question
0

How to connect lidar detected object to map frame with Open Planner?

asked 2020-08-26 07:57:12 -0500

fantasyplus gravatar image

image description

This is in velodyne frame and I select packages below:

  • ray_ground_filter
  • lidar_euclidean_cluster_detect
  • wf_simulator
  • twist_filter

image description

This is in world frame and I select packages below:

  • op_global_planner
  • wf_simulator(with gnss localization)
  • twist_filter

How can those two show together?

Beacuse I want to use op_local_planner to avoid obstacle.

But I dont't know how to mix them together and implement normal op planner's plan with wf_simulator.

  • autoware version:1.14
  • operating system:Ubuntu18.04
  • Ros version:melodic
edit retag flag offensive close merge delete

Comments

@Hatem Hi,can you help me with that problem?May be easy for you:)

fantasyplus gravatar image fantasyplus  ( 2020-08-26 08:02:22 -0500 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2020-08-26 10:14:48 -0500

Hatem gravatar image

Hello fantasyplus,

Unfortunately because you are using Autoware 1.14 this will not work out of the box. you need to check the frames and topic names.

One simple solution is to set output frame in euclidean cluster node to "map", and use lidar_kf_contour_tracker.

If you are willing to use Autoware 1.13 , then you can switch to repository from https://gitlab.com/hatem-darweesh-aut...

openplanner.1.13 branch

Then everything should work out of the box.

edit flag offensive delete link more

Comments

Thanks.

Btw,Why Op Flag doesn't show with open planner?It can show with dp_planner which is old version.

I want to simulate a obstacle on the global path,but when I push Publish Point,rviz will crash.

fantasyplus gravatar image fantasyplus  ( 2020-08-27 01:59:35 -0500 )edit

can you elaborate, I didn't get what you are trying to do.

Hatem gravatar image Hatem  ( 2020-08-27 02:34:48 -0500 )edit

I want to set a simulated obstacle on the global path to check the open planner's obstacle avoidance.

Normal way is publish point,but my rviz will break down,I.search Google find autoware has an Op Flag also has an obstacle function.

I tried dp planner and the Op Flag shows as an obstacle,then the wf_simualtor bypass the Op Flag when using pure_pursuit , but when I tried op planner,the Op Flag didn't show as an obstacle when I clicked mouse.

Anyway,I just want to verify op planner's obstacle avoidance,do you have a better idea?I have a real car and can implement lidar detection with euclidean cluster and kf_contor_track.

fantasyplus gravatar image fantasyplus  ( 2020-08-27 02:53:59 -0500 )edit

dp planner is the old version,

please use OpenPlanent 1.5 (op_global_planner, op_local_planner)

you will find everything you need in this tutorial

you can setup a simulated vehicle (set its velocity to 0 if you want it to work as static obstacle)

in the autoware 1.3, 1.14 only one op_car_simulator is shown in the runtime manage, but you can still run other op_car_simulator from the command line.

if you want to just insert one point by mouse, I fixed the issue of rviz crashing by using 2D Nav Goal. but this solution is available only in my fork which I mentioned in my answer.

Hatem gravatar image Hatem  ( 2020-08-27 04:16:36 -0500 )edit

thank you.I changed frame and topic name,the wf_simulator can avoid the op_car_simulator.

But when I run my rosbag,op_motion_predictor doesn't show the topic"/predicted_trajectories_rviz".

the error info is "scale.y and scale.z of LINE_LIST or LINE_STRIP are ignored.

Points should not be empty for specified marker type.

At least two points are required for a LINE_STRIP marker".

Looks like predictor sends empty predicted information,so the evaluator doesn't consider it as a trajectory_cost.

Do you know why? This is the final step so I can connect all subsyetem together to let my real car move:(

Here is my bag. https://drive.google.com/file/d/1D9xx...

fantasyplus gravatar image fantasyplus  ( 2020-08-27 22:37:27 -0500 )edit

I find my problem....just click off enable openplanner perception simulation

fantasyplus gravatar image fantasyplus  ( 2020-08-27 23:48:16 -0500 )edit

glad that you get it to work

Hatem gravatar image Hatem  ( 2020-08-28 00:02:27 -0500 )edit

@Hatem We are also attempting to get the lidar detected objects to be avoided when using OpenPlanner. We are currently using the 1.13 branch that you have created. We can see the detected objects on the map but wf_simulator/pure_pursuit seem to just ignore them. We are using kf_contour_track and have turned off enable openplanner perception simulation. We are using the range_vision_fusion node for sensor fusion as well. What would you suggest for us to try?

fisc8617 gravatar image fisc8617  ( 2021-03-18 16:21:05 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

5 followers

Stats

Asked: 2020-08-26 07:57:12 -0500

Seen: 456 times

Last updated: Aug 26 '20