Ask Your Question
0

Sourcing catkin workspace to include its packages disables rqt

asked 2020-08-16 02:18:37 -0500

Driss gravatar image

updated 2021-04-24 02:36:07 -0500

Hello,

I'm running ros melodic latest version on ubuntu bionic 18.04, I've installed with app-get, I need to create and implement rqt plugins, when I source the catkin workspace it disables the rqt plugin recognition and it can't find the plugins from common-plugins or robot-plugins. I get error msg with CompositePluginProvider.discover() method. It seems rqt tries to find plugins within my new workspace. Is there a way to source without disabling the plugins from rqt?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-08-22 14:53:59 -0500

Driss gravatar image

The problem was in the sourcing, I added the workspace effectively overwritting the ros/melodic/share installed by the original source of /opt/ros/melodic/setup.bash. So far my solution is to add the individual packages of the catkin ws instead of directly sourcing the ws. So add to .bashrc "export ROS_PACKAGE_PATH=path/to/your_package:$ROS_PACKAGE_PATH" as mentioned in one of the old tutorials. This allows the complete rqt library to exist alongside your custom packages within your ros environnment.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2020-08-16 02:18:37 -0500

Seen: 13 times

Last updated: Aug 16 '20