Ask Your Question
1

Cannot figure out what's going on with python3-rosdep2

asked 2020-08-15 02:40:56 -0500

towood gravatar image

updated 2020-08-17 09:25:48 -0500

sloretz gravatar image

I'm following the instructions for installing ROS2 here and I keep getting the error

sudo: rosdep: command not found

when I run sudo update init. Looking through the files installed in the package python3-rosdep2, I don't see any executable. I tried sudo python3 -m rosdep2 init and it says

/usr/bin/python3: No module named rosdep2.__main__; 'rosdep2' is a package and cannot be directly executed

So I have no idea what to do next. I created an issue on github and was told to ask my question here. After following the instructions given on github I still cannot execute the steps to install and use python3-rosdep2.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2020-08-17 09:24:24 -0500

sloretz gravatar image

updated 2020-08-17 09:27:06 -0500

The comment on github has the answer. Uninstall python3-rosdep2, and install python3-rosdep or python-rosdep. python3-rosdep2 is an older version. See this question for more info.

https://answers.ros.org/question/3530...

sudo apt-get purge python-rosdep2 python3-rosdep2
sudo apt-get install python3-rosdep
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2020-08-15 02:39:23 -0500

Seen: 839 times

Last updated: Aug 17 '20