What should I do with 'link was not found' error in Gazebo?

asked 2020-08-13 18:28:51 -0500

doubleJ gravatar image

updated 2020-08-13 18:37:23 -0500

Hello.

I am trying to make a UR5 model grip a box in Gazebo.

I am using Ubuntu 16.04, ROS kinetic, Gazebo 7, Openrave, and Moveit with the following packages:

criros gazebo_ros_link_attacher gazebo_ros_pkgs robotiq_85_gripper universal_robot

However, when I run the simulation and as the model grasp the box, I got the following error message:

[ INFO] [1597297578.909688428, 272.106000000]: Received request to attach model: 'robot' using link: 'wrist_3_link' with model: 'simplebox' using link: 'link'
[ INFO] [1597297578.909803393, 272.106000000]: Creating new joint.
[ERROR] [1597297578.909907566, 272.106000000]: wrist_3_link link was not found
gzserver: /usr/include/boost/thread/pthread/recursive_mutex.hpp:113: void boost::recursive_mutex::lock(): 
Assertion `!pthread_mutex_lock(&m)' failed.
Aborted (core dumped)
[gazebo-2] process has died [pid 17991, exit code 134, cmd 
/home/jjy/URonly/src/gazebo_ros_pkgs/gazebo_ros/scripts/gzserver -e ode 
/home/jjy/URonly/src/universal_robot/ur_gazebo/world/simpleboxUR.world __name:=gazebo __log:=/home/jjy/.ros/log/ccbeb9ec-dd27-11ea-88b6-d05099450560/gazebo-2.log].

log file: /home/jjy/.ros/log/ccbeb9ec-dd27-11ea-88b6-d05099450560/gazebo-2*.log

What should I do to solve this error?

I would appreciate any answer to solve, or at least, what caused this error.

Thank you.

edit retag flag offensive close merge delete

Comments

1

@doubleJ, Can you post your actual robot description, with that little information can be hard to debug what is happening.

Weasfas gravatar image Weasfas  ( 2020-08-15 06:33:50 -0500 )edit

@Weasfas, The name of the link 'wrist_3_link' didn't match with the description in the controller. After fixing that, the error was solved.

doubleJ gravatar image doubleJ  ( 2020-08-18 01:41:31 -0500 )edit