Failed to build locomotor package by using catkin_make_isolated --install --use-ninja [closed]

asked 2020-08-11 08:09:03 -0500

PiyushThapar gravatar image

updated 2021-04-24 02:36:54 -0500

miura gravatar image

Hi, I am unable to build locomotor package while using catkin_make_isolated --install --use-ninja. Error its showing up is NavCore2Exception Ptr' is not a member of 'nav_core2'

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by PiyushThapar
close date 2020-08-22 02:00:10.871470


Please do not cross post:

Which distro and branch of this repo are you using? Please post the full error log.

David Lu gravatar image David Lu  ( 2020-08-12 15:06:17 -0500 )edit

Sorry for cross-post but I solved my problem by manually adding nav-core2 package

PiyushThapar gravatar image PiyushThapar  ( 2020-08-19 04:30:56 -0500 )edit

Locomotor already depends on nav_core2 ( so was this just an issue of not havin gthe dependencies installed?

David Lu gravatar image David Lu  ( 2020-08-20 12:20:34 -0500 )edit

Actually I downloaded the locomotor package as I wanted to make some changes in the package and the rest of the robot navigation packages, I installed them, but somehow compiler was giving the error of not able to find the rest of the packages so I downloaded rest of the packages too and it worked.

PiyushThapar gravatar image PiyushThapar  ( 2020-08-21 01:47:17 -0500 )edit