Ask Your Question
0

Autoware NDT_Matching with ouster-128

asked 2020-08-10 08:53:45 -0500

ken86202 gravatar image

updated 2021-04-24 03:06:49 -0500

Hello,

I want to run Autoware NDT_Matching with ouster-128

I am getting a transform error For frame [/os1_lidar]: No transform to fixed frame [world]. TF error: [, when looking up transform from frame [os1_lidar] to frame [world]]

I have tested many parameters,

  • voxel_grid_filter
  • ndt_matching

but it can’t transform [/os1_lidar] -> [world] correctly.

Environment: Ubuntu 16.04, ROS Kinetic, Autoware 1.12.0

edit retag flag offensive close merge delete

Comments

Did you define a transform from map->world? NDT matching should create a transform relative to map frame.

Patrick N. gravatar image Patrick N.  ( 2020-08-10 13:06:33 -0500 )edit

Yes I have loaded tf_local.launch (map->world) ,and I have error

For frame [/os1_lidar]: No transform to fixed frame [world]. TF error: [Lookup would require extrapolation into the past. Requested time 1550.048495240 but the earliest data is at time 1597062760.654010145, when looking up transform from frame [os1_lidar] to frame [world]]

ken86202 gravatar image ken86202  ( 2020-08-10 22:44:42 -0500 )edit

Are you replaying recorded data?

Patrick N. gravatar image Patrick N.  ( 2020-08-10 22:45:53 -0500 )edit

yes I play rosbag

ken86202 gravatar image ken86202  ( 2020-08-10 22:51:07 -0500 )edit

Are you using the simulation tab on the gui or setting the use_sim_time rosparam. Seems like some part of your TF tree is using system time and another part using something else.

Patrick N. gravatar image Patrick N.  ( 2020-08-10 22:52:56 -0500 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2020-08-13 12:14:32 -0500

Josh Whitley gravatar image

By default, Autoware.AI does not understand the frame /os1_lidar because it assumes that the lidar's frame is /velodyne. There are a few ways to correct this:

  1. Change your Ouster driver to publish the point clouds with the frame velodyne. (easiest)
  2. Change the code / launch files / configuration files to expect the frame os1_lidar. (hardest)
  3. Change the localizer parameter in ndt_matching to os1_lidar and publish a static transform between os1_lidar and velodyne with parameters 0 0 0 0 0 0. (this is unttested but may work)
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2020-08-10 08:43:50 -0500

Seen: 209 times

Last updated: Aug 13 '20