Ask Your Question
0

VLP16-HiRes doubled lines in cloud

asked 2020-08-09 03:42:02 -0500

jerperfa gravatar image

updated 2020-08-10 03:21:48 -0500

--Solved--

Dear all

At the moment I'm working on a rc-car, which has mounted a VLP16-HiRes on top of it. For processing the cloud and all other stuff a nVidia Jetson Xavier developer kit is mounted on the car. The OS is from nVidia, but is based on Ubuntu 18.04. The used ROS distro is melodic.

To achiv a non distorted cloud with the VLP16-HiRes, I changed the calibration file in the launch file

/opt/ros/melodic/share/velodyne_pointcloud/launch/VLP16_points.launch

to the correct file for the Hi-Res Puck (Line 7):

   arg name="calibration" default="$(find velodyne_pointcloud)/params/VLP16_hires_db.yaml

Of course I make sure, that on the Web-Interface of the Sensor also the return mode is set to "Strongest" (as mentioned here for example).

As I understood it right, the ROS cannot make changes in the Velodyne settings (such as return mode, rpm, and so on).

So far everything is fine, as long as the car is not moving. As soon as I start moving I got all lines twice: Bellow you can find a little snipped of rviz (from the /velodyne_points topic):

image description

Further I calculated for an object the estimated number of points. To be more precise I calculated the highest amount of points which I would the object expect to have. The cloud which represents the object, has more than the maximal possible amount of points. The one and only explanation I found, is that I'm running in the dual return mode.

As mentioned in several other posts and sources, I would expect the parameters of the ROS-File not to change anything on the sensor.

The comment in this post here says that probably the constant

VLP16_FIRINGS_PER_BLOCK = 2

could affect this. But I'm a bit aware of just changing the a constant, without any further understanding what it is used for.

I would appreciate it very much if someone can give me a hint how to solve the problem.

Best regards jerperfa

Update: I tested resetting (compiling and installing the library) with

VLP16_FIRINGS_PER_BLOCK = 1

Result: Size of cloud is reduced by halve, but I still have this second line. Can the movement of the car cause this line?

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2020-08-10 03:19:11 -0500

jerperfa gravatar image

updated 2020-10-14 08:29:51 -0500

I just find a solution to solve this problem.

In the webinterface I changed the Field of view parameter, since I'm not using the whole revolution. My settings are: start 270 and end 90

As I've seen the Ros interface is not affected by this parameters. I also read this somewhere, but don't remember where.

Tests have shown, that the problem was caused by this setting. To avoid the above shown bad situation you have two options:

  1. set the parameter "cut_angle" in the .launch file to Pi

    name="cut_angle" default="3.1415"

  2. Change back the setting of the Lidar to Field of view start: 0 end: 359

If it's not necessary for you to have another field of view, I would recommend the second solution, since Ros got anyway the whole cloud. Reducing the size does not save time nor network capabilities.

Best regards and hope this solution might help someone jerperfa

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2020-08-08 15:37:34 -0500

Seen: 171 times

Last updated: Oct 14 '20