Add the installation prefix of "rslidar_msgs" to CMAKE_PREFIX_PATH

asked 2020-06-11 12:51:30 -0500

rechuin gravatar image

updated 2020-06-11 14:39:55 -0500

gvdhoorn gravatar image

I'm a beginner in ROS, and I'm using the version of ROS for windows. ros package for robosense lidar So I'm in windows. This is done through a CMD window. But I've met 2 problem:

  1. how to install libpcap-dev in ROS for windows
  2. when compiling, I encounter the following problem, I put the error trace below, how to fix it

    CMake Error at C:/opt/ros/melodic/x64/share/catkin/cmake/catkinConfig.cmake:83 (find_package):
      Could not find a package configuration file provided by "rslidar_msgs" with
      any of the following names:
    
        rslidar_msgsConfig.cmake
        rslidar_msgs-config.cmake
    
      Add the installation prefix of "rslidar_msgs" to CMAKE_PREFIX_PATH or set
      "rslidar_msgs_DIR" to a directory containing one of the above files.  If
      "rslidar_msgs" provides a separate development package or SDK, be sure it
      has been installed.
    Call Stack (most recent call first):
      CMakeLists.txt:24 (find_package)
    
edit retag flag offensive close merge delete

Comments

2

@rechuin It means you will need to git clone the rslidar_msgs' repository into your workspace, so that catkin can find and build it. Alternatively, you can check out this, where it documents the generic workflow how one to consume a ROS package.

Sean Yen gravatar image Sean Yen  ( 2020-06-11 16:44:23 -0500 )edit