Ask Your Question
0

Rosbridge and Node Red communication trouble

asked 2020-05-14 09:49:34 -0500

yassine gravatar image

updated 2020-05-14 09:51:27 -0500

Hi everyone, I'm trying to establish communication between Rosbridge and Node Red, so I'm using ros_publish node from Node-Red-contrib-ros in Node Red, and even after adding the ROS server address (ws://0.0.0.0:9090) to the node I can't get it to connect to Rosbridge.

The following error appears "[error] [ros-server:ebb28890.372cf8] TypeError: util.debug is not a function"

Can anyone tell me what is missing to establish the communication?

Thank you in advance

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2021-05-07 06:24:42 -0500

Y2D2 gravatar image

Hi Yassine,

Not sure if this is still valid for you, but I experienced the same issue with the ros library in Node red. I was not able to get it to work, but figured out how to directly use the websocket nodes in Node red to circumvent the issue and establish communication with ROS.

I have described the steps here :

https://docs.google.com/document/d/1g...

Because apparently there is a rule that you cannot include images in your answer when you have less then 5 points? ( I do not see how this rule is contributing to share knowledge... )

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2020-05-14 09:49:34 -0500

Seen: 164 times

Last updated: May 14 '20