Ask Your Question
0

Build error ; library not found

asked 2020-04-28 07:55:28 -0500

shmpwk gravatar image

updated 2020-04-29 01:04:55 -0500

I followed this README but have a trouble when building.

My environment is Ubuntu 18.04, melodic.

I understand this problem should be posted as issue on this repository, but I think my problem is not specific problem in this repository.

Following this,I installed GPD and confirmed that it works.

After cloning this repository and moving to my work space, I tried catkiin build gpd_ros.

But error occurred saying:

[build] Found '86' packages in 0.0 seconds.                                    
[build] Package table is up to date.                                           
Starting  >>> gpd_ros                                                          
Errors     << gpd_ros:cmake /home/shumpeiwakabayashi/ow_ws/logs/gpd_ros/build.cmake.001.log
** WARNING ** io features related to ensenso will be disabled
** WARNING ** io features related to davidSDK will be disabled
** WARNING ** io features related to dssdk will be disabled
** WARNING ** io features related to pcap will be disabled
** WARNING ** io features related to png will be disabled
** WARNING ** io features related to libusb-1.0 will be disabled
** WARNING ** visualization features related to ensenso will be disabled
** WARNING ** visualization features related to davidSDK will be disabled
** WARNING ** visualization features related to dssdk will be disabled
** WARNING ** visualization features related to rssdk will be disabled
CMake Error at /home/shumpeiwakabayashi/ow_ws/src/gpd2_ros/CMakeLists.txt:20 (message):
  Library GPD not found


cd /home/shumpeiwakabayashi/ow_ws/build/gpd_ros; catkin build --get-env gpd_ros | catkin env -si  /usr/bin/cmake /home/shumpeiwakabayashi/ow_ws/src/gpd2_ros --no-warn-unused-cli -DCATKIN_DEVEL_PREFIX=/home/shumpeiwakabayashi/ow_ws/devel/.private/gpd_ros -DCMAKE_INSTALL_PREFIX=/home/shumpeiwakabayashi/ow_ws/install; cd -
...............................................................................
Failed     << gpd_ros:cmake          [ Exited with code 1 ]                    
Failed    <<< gpd_ros                [ 2.2 seconds ]                           
[build] Summary: 0 of 1 packages succeeded.                                    
[build]   Ignored:   85 packages were skipped or are blacklisted.              
[build]   Warnings:  None.                                                     
[build]   Abandoned: None.                                                     
[build]   Failed:    1 packages failed.                                        
[build] Runtime: 2.7 seconds total.

Looking at CMakeList.txt:16,

find_library(GPD_LIB NAMES gpd PATHS /usr/local/lib PATH_SUFFIXES lib NO_DEFAULT_PATH)

So I put gpd folder in /usr/local/lib. (gpd folder is not library but the source folder.)

But again the same error.

I checked How to find libraries on the cmake tutorial, but couldn't be solved.

How should I tackle with this problem?

Thank you in advance!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-04-29 02:20:16 -0500

shmpwk gravatar image

I moved to /$(PATH_TO_gpd)/gpd/build, tried sudo make install and succeeded to use GPD as shared library.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2020-04-28 07:55:28 -0500

Seen: 370 times

Last updated: Apr 29 '20