"OSError: [WinError 193] %1" When Running "ros2 run rqt_console rqt_console"

asked 2020-04-28 03:22:04 -0500

songyuc gravatar image

updated 2020-04-28 04:24:33 -0500

gvdhoorn gravatar image

Hi guys, I am learning the ROS2 on Windows by the tutorials. I meet an error "OSError: [WinError 193] %1" when running "ros2 run rqt_console rqt_console", and the detail output is:

Traceback (most recent call last):
File "E:\dev\ros2-eloquent\ros2-windows\Scripts\ros2-script.py", line 11, in <module> load_entry_point('ros2cli==0.8.7', 'console_scripts', 'ros2')()
File "E:\dev\ros2-eloquent\ros2-windows\Lib\site-packages\ros2cli\cli.py", line 69, in main rc = extension.main(parser=parser, args=args)
File "E:\dev\ros2-eloquent\ros2-windows\Lib\site-packages\ros2run\command\run.py", line 72, in main return run_executable(path=path, argv=args.argv, prefix=prefix)
File "E:\dev\ros2-eloquent\ros2-windows\Lib\site-packages\ros2run\api__init__.py", line 61, in run_executable process = subprocess.Popen(cmd)
File "c:\python37\lib\subprocess.py", line 800, in __init__ restore_signals, start_new_session)
File "c:\python37\lib\subprocess.py", line 1207, in _execute_child startupinfo)
OSError: [WinError 193] %1 is not a valid Win32 application.

Any answer and idea will be appreciated!

edit retag flag offensive close merge delete

Comments

1

I have the exact same problem in the tutorial (new to ROS), no clue how to fix it but I was able to get around it by going into a cmd terminal and opening rqt. Then in the toolbar I clicked "Plugins" > "Logging" > "Console". I was able to complete the tutorial that way. Hope that helps!

neeewton gravatar image neeewton  ( 2020-05-10 20:15:38 -0500 )edit

I found the same problem, rqt_console.exe is not there. I built from scratch and still not there.

pauceano gravatar image pauceano  ( 2020-08-15 21:44:02 -0500 )edit

Same error here. Seems a bug fix was added a week ago; waiting for release. More details here: https://github.com/ros-visualization/...

sabin gravatar image sabin  ( 2021-02-01 14:11:25 -0500 )edit