Ask Your Question
2

ROS2 rqt_tf_tree emits service not available, waiting again...

asked 2020-04-11 17:39:53 -0600

mequi gravatar image

I am running ROS2 eloquent on Ubuntu 18.04 and just performed a sudo apt-get install ros-eloquent-rqt-tf-tree and tried running the command in the terminal. The first time I ran it I received the error qt_gui_main() found no plugin matching "rqt_tf_tree.tf_tree.RosTfTree". I then ran the same rqt_tf_tree command with --force-discover and after that, I began receiving service not available, waiting again... repeatedly each time I ran it. Both /tf and /tf_static are being published to by the ROS2 robot state publisher. Any help is greatly appreciated.

edit retag flag offensive close merge delete

Comments

I have experienced exactly the same issue (ubuntu 18.04, ROS eloquent). There is also a related issue on the rqt-tf-tree GitHub page and another similar question on ROS-Answer.

Unfortunately, none of these provides a solution to this issue and I was not able to come up with one either.

From what I know tf is still a work in progress in ROS eloquent, thus this currently might even be the "expected" behavior, as some relevant parts might still be missing. (?)

I would really appreciate it if someone could confirm that this is i fact true or rather a configuration issue/bug.

Phgo gravatar image Phgo  ( 2020-04-15 14:14:36 -0600 )edit

Facing the same issue.

webvenky gravatar image webvenky  ( 2020-04-28 01:50:37 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-04-29 09:49:41 -0600

Phgo gravatar image

updated 2020-05-07 07:06:22 -0600

After looking a little deeper into this issue, I will try to form an answer from my findings:

Currently, there is only preliminary support for tf2 in ROS 2, and although rqt_tf_free has been released, some parts of tf2 are apparently still a work in progress.

In order to work properly, rqt_tf_tree relies on the tf2_frames service, which however is not yet available in the latest release of tf2_ros (0.12.5). This pending dependency is also pointed out here. However, the corresponding pull request to reactivate the frame graph service in tf2_ros (https://github.com/ros2/geometry2/pull/198), is still open.

Though this will probably be resolved in one the upcoming releases, I would find it really useful if this could be mentioned somewhere in the readme.

In the meantime, you might want to take a look at view_frames in the tf2_toolspackage (https://github.com/ros2/geometry2/tre...) that allows you to visualize your tf-tree in a similar way. (At the time writing, tf2_tools is not yet available in the package repository, so you need to install it from source.)

Note: if the rqt_tf_tree plugin prevents your rqt-GUI from opening, you simply need to reset your config by rqt --clear-config (see this question)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2020-04-11 17:39:53 -0600

Seen: 2,200 times

Last updated: May 07 '20