Ask Your Question
0

how to run rqt with ubuntu and eloquent, service not available

asked 2020-01-04 09:57:42 -0600

billmania gravatar image

updated 2020-01-04 09:59:57 -0600

I have a clean installation of ROS2 Eloquent on an ubuntu 18.04 system. I'm following the Tutorial https://index.ros.org/doc/ros2/Tutori... First, there's a minor typo in that tutorial in Section 4, Install rqt. The command line

sudo apt install ros-{distro}-rqt-*

will install everything EXCEPT the ros-eloquent-rqt package itself. The command should be changed to:

sudo apt install ros-{distro}-rqt*

More importantly, when I attempt to start rqt with the command line rqt, I get the message service not available, waiting again...

What am I missing? Prior to this section of the tutorial, the turtlesim starts and functions correctly. I've tried to start rqt both with and without the turtlesim running, but the results are the same.

edit retag flag offensive close merge delete

Comments

Same for me - "service not available..."

Thomas B. Lyons gravatar image Thomas B. Lyons  ( 2020-01-05 03:25:00 -0600 )edit

Did you get this error right away or only after using a specific plugin? I experienced the same issue after adding rqt_tf_tree and was wondering if this was the case for you too.

Phgo gravatar image Phgo  ( 2020-04-15 10:56:27 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2020-04-15 11:27:01 -0600

Phgo gravatar image

I think this is caused if one of enabled plugins in rqt is waiting for a service that does not exist. (possibly because the required features are still a work in progress in ROS2?)

Resetting rqt with rqt --clear-config should disable all plugins and allow to reopen rqt in the usual way. This might be advantageous over deleting the whole configuration.

If the issue reappear after adding specific plugin, you know which plugin is causing this. (in my case rqt_tf_tree)

edit flag offensive delete link more
0

answered 2020-01-06 16:58:10 -0600

billmania gravatar image

After reading https://answers.ros.org/question/9123... I solved the problem by removing the directory ~/.config/ros.org.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2020-01-04 09:57:42 -0600

Seen: 435 times

Last updated: Apr 15 '20