Ask Your Question
1

rosed can't find my files in the package i just created how can i fix that?

asked 2020-04-04 10:20:28 -0500

hazemkhaled gravatar image

I am using this command to open Cmakelist file with the rosed command $ rosed my_pack CmakeLists.txt but I am getting this error

find: paths must precede expression: 'WORKSPACES/CH3' That file does not exist in that package.

I did that after sourcing my workspace and rosed command can identify what file I am looking for when I press TAP to autocomplete filename, it lists all files in my package [package.xml CmakeLists.txt *.py *.py ...] so how can I fix that?

edit retag flag offensive close merge delete

Comments

Are you sure the name is CmakeLists.txt? Usually, the name is CMakeLists.txt

Teo Cardoso gravatar image Teo Cardoso  ( 2020-04-05 16:50:08 -0500 )edit

tried CMakeLists.txt but still the same problem , I think it is related to Ros Environment variables specially CMAKE_PREFIX_PATH & ROS_WORKSPACE

hazemkhaled gravatar image hazemkhaled  ( 2020-04-06 15:04:21 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-04-05 15:30:21 -0500

hazemkhaled gravatar image

I think the problem is that ROS environment variables CMAKE_PREFIX_PATH & ROS_WORKSPACE which are both empty in my workspace even I had sourced the setup.bash file and thinks running well in my workspace
thus if anyone know what values I should set these variables with please mention that?

edit flag offensive delete link more

Comments

1

CMAKE_PREFIX_PATH on my computer is: /opt/ros/kinetic and There is no ROS_WORKSPACE variable set.

rosed works properly here.

Teo Cardoso gravatar image Teo Cardoso  ( 2020-04-06 17:21:50 -0500 )edit
1

the problem was with my file name , I didn't follow the naming convention of ROS which was not using any capital letters in directory or package name , thus after editing them and passing through build issues I had it Working properly now thanks @Teo Cardoso your answer helped me a lot to identify the issue

hazemkhaled gravatar image hazemkhaled  ( 2020-04-07 18:08:55 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2020-04-04 10:20:28 -0500

Seen: 115 times

Last updated: Apr 05 '20