Ask Your Question
0

rviz segfault in fuerte

asked 2012-05-25 02:55:21 -0600

yigit gravatar image

updated 2014-01-28 17:12:26 -0600

ngrennan gravatar image

Hello everyone,

I just started using ROS and had a problem with rviz.

rosrun rviz rviz 
[ INFO] [1337948693.539857743]: rviz revision number 1.8.11
[ INFO] [1337948693.540013978]: compiled against OGRE version 1.7.3 (Cthugha)
Segmentation fault (core dumped)

I tried different OGRE modes:

export OGRE_RTT_MODE=Copy
export OGRE_RTT_MODE=FBO

Neither of them worked. I finally get into the bin directory of rviz and debug the exectuable. Here is the result (for the entire output, please see here):

Program received signal SIGSEGV, Segmentation fault.
0x019df739 in QMetaObject::indexOfSignal (this=0x1ad3d34, signal=0x27db89 "changed()") at /var/tmp/qt-x11-src-4.5.3/src/corelib/kernel/qmetaobject.cpp:587
587     /var/tmp/qt-x11-src-4.5.3/src/corelib/kernel/qmetaobject.cpp: No such file or directory.

And for those who are willing to help me - they say in a bug report (here) that there is a script called system_info.sh - I attach the system info here.

Thanks in advance.

edit retag flag offensive close merge delete

Comments

Hi, I have exactly the same error except the rviz revision number is 1.8.17. Have you figured out the root cause of the issue? Thanks

dipsgautam gravatar imagedipsgautam ( 2015-10-19 05:11:04 -0600 )edit

@dipsgautam: this is a very old question (Fuerte is over 5 ROS versions old), so I advise you to post a new question. Do link to this one in your new one though.

gvdhoorn gravatar imagegvdhoorn ( 2015-10-19 05:33:48 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-08-24 00:00:46 -0600

Barton.Qi gravatar image

please read the page http://www.ros.org/wiki/rviz/Troubleshooting#Segfault_during_startup

and try each mode of these: copy PBuffer FBO, maybe one of them will work!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-05-25 02:55:21 -0600

Seen: 633 times

Last updated: Aug 24 '12