Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

rviz segfault in fuerte

Hello everyone,

I just started using ROS and had a problem with rviz.

rosrun rviz rviz 
[ INFO] [1337948693.539857743]: rviz revision number 1.8.11
[ INFO] [1337948693.540013978]: compiled against OGRE version 1.7.3 (Cthugha)
Segmentation fault (core dumped)

I tried different OGRE modes:

export OGRE_RTT_MODE=Copy
export OGRE_RTT_MODE=FBO

Neither of them worked. I finally get into the bin directory of rviz and debug the exectuable. Here is the result (for the entire output, please see here):

Program received signal SIGSEGV, Segmentation fault.
0x019df739 in QMetaObject::indexOfSignal (this=0x1ad3d34, signal=0x27db89 "changed()") at /var/tmp/qt-x11-src-4.5.3/src/corelib/kernel/qmetaobject.cpp:587
587     /var/tmp/qt-x11-src-4.5.3/src/corelib/kernel/qmetaobject.cpp: No such file or directory.

And for those who are willing to help me - they say in a bug report (here) that there is a script called system_info.sh - I attach the system info here.

Thanks in advance.

rviz segfault in fuerte

Hello everyone,

I just started using ROS and had a problem with rviz.

rosrun rviz rviz 
[ INFO] [1337948693.539857743]: rviz revision number 1.8.11
[ INFO] [1337948693.540013978]: compiled against OGRE version 1.7.3 (Cthugha)
Segmentation fault (core dumped)

I tried different OGRE modes:

export OGRE_RTT_MODE=Copy
export OGRE_RTT_MODE=FBO

Neither of them worked. I finally get into the bin directory of rviz and debug the exectuable. Here is the result (for the entire output, please see here):

Program received signal SIGSEGV, Segmentation fault.
0x019df739 in QMetaObject::indexOfSignal (this=0x1ad3d34, signal=0x27db89 "changed()") at /var/tmp/qt-x11-src-4.5.3/src/corelib/kernel/qmetaobject.cpp:587
587     /var/tmp/qt-x11-src-4.5.3/src/corelib/kernel/qmetaobject.cpp: No such file or directory.

And for those who are willing to help me - they say in a bug report (here) that there is a script called system_info.sh - I attach the system info here.

Thanks in advance.

rviz segfault in fuerte

Hello everyone,

I just started using ROS and had a problem with rviz.

rosrun rviz rviz 
[ INFO] [1337948693.539857743]: rviz revision number 1.8.11
[ INFO] [1337948693.540013978]: compiled against OGRE version 1.7.3 (Cthugha)
Segmentation fault (core dumped)

I tried different OGRE modes:

export OGRE_RTT_MODE=Copy
export OGRE_RTT_MODE=FBO

Neither of them worked. I finally get into the bin directory of rviz and debug the exectuable. Here is the result (for the entire output, please see here):

Program received signal SIGSEGV, Segmentation fault.
0x019df739 in QMetaObject::indexOfSignal (this=0x1ad3d34, signal=0x27db89 "changed()") at /var/tmp/qt-x11-src-4.5.3/src/corelib/kernel/qmetaobject.cpp:587
587     /var/tmp/qt-x11-src-4.5.3/src/corelib/kernel/qmetaobject.cpp: No such file or directory.

And for those who are willing to help me - they say in a bug report (here) that there is a script called system_info.sh - I attach the system info here.

Thanks in advance.