Ask Your Question
0

gmapping Detected jump back in time of. Clearing TF buffer.

asked 2020-03-10 12:37:15 -0600

xinxinxin gravatar image

updated 2020-03-10 16:53:36 -0600

Hi everyone

I am running gmapping with my own bag (in which I drive turtlebot with turtlebot_telop node, drive the robot go around the simulation environment.)

Then I start roscore, set use_sim_time true, run gmapping, play the bag file.

The gmapping works, but terminal sometimes outputs

[ WARN] [1583861539.918718206, 587.563370629]: Detected jump back in time of 0.000629371s. Clearing TF buffer.

It seems like there was a jump in the timestamp? It is the problem with my bag file of the gamapping settings?

Thank you!

------updates-----

I set the /use_sim_time to 0.1, now it works fine without warning.

edit retag flag offensive close merge delete

Comments

Are you running rosbag play with the --clock option?

gvdhoorn gravatar image gvdhoorn  ( 2020-03-10 16:20:06 -0600 )edit

yes I did. I guess the problem is /use_sim_true. I set it to 0.1 then warning disappeared.

xinxinxin gravatar image xinxinxin  ( 2020-03-10 16:52:41 -0600 )edit

0.1 is not a legal value for use_sim_time. It's supposed to be a boolean. Not a float.

gvdhoorn gravatar image gvdhoorn  ( 2020-03-10 16:59:30 -0600 )edit

Yes, I understand it is a boolean. I can't remember in which slam system, I get the /use_sim_time, got a result of 0.1. But you are right, it is a boolean.

xinxinxin gravatar image xinxinxin  ( 2020-04-02 15:10:15 -0600 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2020-03-11 00:07:16 -0600

You’re fine.

What that means is that the clock is switching from real to simulated so the timestamp is jumping.

You can solve this by starting roscore, setting sim time before launching a node since the nodes won’t be up yet to experience the jumps.

You’ll see this message as well if you run a bag twice since the stamps will jump on the rerun to the beginning.

As long as things are working, don’t worry about the message.

edit flag offensive delete link more

Comments

Hi, Thank you for answering. Is that right if the message jumps out during playing a bag file. If i understand is correct, The clock shouldn't frequently switching during the system running. for example, I run roscore, set the sim time true, roslaunch SLAM, play --clock bag. At the beginning, there will be some clock jump message. Okay, maybe the system need few seconds to adjust the clock. But what if the message frequently shows up?

xinxinxin gravatar image xinxinxin  ( 2020-04-02 15:16:50 -0600 )edit
1

That is correct. It should not show up frequently or else you have something else also resetting the clock or not all your nodes are using the same clock.

stevemacenski gravatar image stevemacenski  ( 2020-04-02 15:51:20 -0600 )edit

Oh, sounds not good. I just roscore, set /use_sim_time true, roslaunch turtlebot3_slam turtlebot3_slam slam_methods:=gmapping, rosbag play --clock mybag. the bag was recorded by record all.

I guess this will cost a lot of time to find out.

xinxinxin gravatar image xinxinxin  ( 2020-04-02 15:55:24 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2020-03-10 12:37:15 -0600

Seen: 1,995 times

Last updated: Mar 11 '20