Ask Your Question

Move physical 'e'- Series Robot with Universal_Robots_ROS_Driver, steps vorgotten?

asked 2020-02-10 07:50:44 -0500

Wifi-cable gravatar image

I Use ROS Melodic on Ubuntu 18.04 (on an old Del laptop)

I have installed the current universal_robots_driver as instructed on GitHub. driver

Than I followed the instructions for an e-series setup. urcaps After getting error messages, because "follow_joint_trajectory" was not found, I edited the controllers.yaml file as suggested in Issue55 . That fixed the error. The robot is turned on, in external control mode, speed is 100 and the connection to the Robot works. (my terminal shows me all the proper Robot info such as when the emergency stop has been pushed)

Using the demo.launch with the fake controller worked well in RVIZ. Next I wanted to move the real Robot. to do that I tried:

roslaunch ur_robot_driver ur3e_bringup.launch robot_ip:=<placeholder_for_real_ip>

The last info it displayes is "Send program to robot" . Next I launched moveit planing execution.

roslaunch ur3_e_moveit_config ur3_e_moveit_planning_execution.launch sim:=false limited:=true

this produced a some warnings:

[ INFO] []: Loading robot model 'ur3e'...
[ WARN] []: Skipping virtual joint 'fixed_base' because its child frame 'base_link' does not match the URDF frame 'world'
[ INFO] []: No root/virtual joint specified in SRDF. Assuming fixed joint

Choosing "world" instead of "base" means that I can not rotate the camera around the robot in RVIZ anymore. I'm too inexperienced with ROS to fully understand why. when I start RVIZ:

roslaunch ur3_e_moveit_config  moveit_rviz.launch config:=true

I get:

[ INFO] []: Added FollowJointTrajectory controller for 
[ INFO] []: Returned 1 controllers in list
[ INFO] []: Trajectory execution is managing controllers
Loading 'move_group/ApplyPlanningSceneService'...
Loading 'move_group/ClearOctomapService'...
Loading 'move_group/MoveGroupCartesianPathService'...
Loading 'move_group/MoveGroupExecuteService'...
[ERROR] []: Exception while loading move_group capability 'move_group/MoveGroupExecuteService': MultiLibraryClassLoader: Could not create object of class type move_group::MoveGroupExecuteService as no factory exists for it. Make sure that the library exists and was explicitly loaded through MultiLibraryClassLoader::loadLibrary()

I'm not sure what this error means or where it comes from, but I suspect it is important. Next I tried to use RVIZ to plan and execute a path. (to move the real robot a few centimeters) I 'm not 100% sure what the output means.

[ INFO] []: Starting planning scene monitor
[ INFO] []: Listening to '/move_group/monitored_planning_scene'
[ INFO] []: Constructing new MoveGroup connection for group 'manipulator' in namespace ''
[ INFO] []: Ready to take commands for planning group manipulator.
[ INFO] []: Looking around: no
[ INFO] []: Replanning: no
[ INFO] []: Marker 'EE:goal_ee_link/10': mesh_use_embedded_materials is ignored.
[ INFO] []: ABORTED: Solution found but controller failed during execution

The real robot never moved with ROS. It does not work with a simple python script for the Move commander either (It is functional when using the teach panel with out ROS) -Did I forget a critical step?
-Did I use the proper procedures to move the robot?

edit retag flag offensive close merge delete


After reading a lot of GitHub issues, I tried temporarily setting the number format to English in each terminal. (export LC_NUMERIC="en_US.UTF-8")

I tried editing the move_group Launchfile as suggested in Universal Robots GitHub Issue 413 . That got writ of the Exception for the "MoveGroupExecuteService" when launching the robots MoveIT config.

My real robot still does not move though.

MoveIt : "Execution request recived"

Robots driver: "Sent program to robot"

Wifi-cable gravatar image Wifi-cable  ( 2020-02-11 06:17:13 -0500 )edit

I would suggest you post an issue on the issue tracker.

gvdhoorn gravatar image gvdhoorn  ( 2020-02-11 06:27:20 -0500 )edit

1 Answer

Sort by » oldest newest most voted

answered 2020-02-18 03:40:50 -0500

Wifi-cable gravatar image

My problem was a connection issue. I did not expect this, since I got valid data from the Robot.

On the robots Teach Pendant, in the Installation tap, go to the menu point "Fieldbus". Make sure that EtherNet/IP is disabled.

If the ethernet is not disabled, the robot will drop the connection also, robot may go into protective stop. Re-enabling the robot does not mean that the robot will work. ROS, Teach pendant or UR driver will not show any errors in this case.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools



Asked: 2020-02-10 07:50:44 -0500

Seen: 291 times

Last updated: Feb 18 '20