sound_play no sound, no error

asked 2020-01-29 12:20:17 -0600

lotharchris gravatar image

updated 2020-01-29 12:21:37 -0600

ROS Kinetic

Running on a paspberry pi 3 b+

USB speaker attached.

I have tried everything I could find on troubleshooting this.

At first I couldn't get any sound even using non-ROS command (aplay).

But after using PulseAudio (pacmd) to set the default source and sink and blacklisting the built-in sound card, aplay will play sounds.

But sound_play will not.

This works fine:

$ aplay /usr/share/sounds/alsa/Side_Left.wav

When I try the below, it shows the message sent and received, but no sound. No errors.

rosrun sound_play soundplay_node.py

It returns:

sound_play node is ready to play sound

Then in new terminal I enter:

rosrun sound_play say.py "hello world"

It returns:

Saying: hello world

Voice: voice_kal_diphone

Volume: 1.0

On the first terminal, where I started the node, it returns:

sound: -3

command: 1

volume: 1.0

arg: "hello world"

arg2: "voice_kal_diphone"

So, it appears to work, but no sound.

Any direction is appreciated.

edit retag flag offensive close merge delete

Comments

I unplugged the USB speaker and plugged in a powered speaker to the headphone jack. aplay works, but still no sound using sound_play. Is there some sound control that sound_play uses that aplay doesn't? Any direction is appreciated.

lotharchris gravatar image lotharchris  ( 2020-03-03 21:43:52 -0600 )edit