Ask Your Question
0

lidar is detecting pillars of robots as obstacles in local map.how to set minimum range of scan sensor or any other method to solve this problem

asked 2020-01-21 04:24:03 -0500

vishrut gravatar image

i have placed my rplidar a1 sensor in the middle of 4 pillar robot. now during navigation it detecting pillars as local obstacle.please help

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
2

answered 2020-01-21 09:17:30 -0500

tryan gravatar image

updated 2020-01-21 09:19:26 -0500

Are you talking about a local cost map? If you are using the obstacles layer, there is a footprint_clearing_enabled parameter, which defaults to true. Make sure it is not set accidentally set to false. If it's still not clearing, ensure that your footprint is properly defined. This is also important for avoiding obstacles in general.

That said, the laser_filters package (as Procópio suggested) is probably also useful as it will remove the pillars from the data stream completely. This will likely improve the quality of SLAM and other applications of your lidar data.

edit flag offensive delete link more
0

answered 2020-01-29 05:54:05 -0500

vishrut gravatar image

I got the solution that exporting urdf from solid work will solve the problem .And then no need to use laser_filter package

edit flag offensive delete link more
0

answered 2020-01-21 05:34:26 -0500

Procópio gravatar image

You can filter it using the laser_filters package. See an example here: http://wiki.ros.org/laser_filters#Las...

edit flag offensive delete link more

Comments

is there any possibility of clearing from mesh and urdf

vishrut gravatar image vishrut  ( 2020-01-21 05:52:32 -0500 )edit

what do you mean?

Procópio gravatar image Procópio  ( 2020-01-22 06:30:24 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2020-01-21 04:24:03 -0500

Seen: 47 times

Last updated: Jan 29