eigenpy moveit_commander - ImportError undefined symbol [closed]

asked 2020-01-15 06:45:31 -0600

lucarinelli gravatar image

updated 2020-01-22 03:39:24 -0600

Hi all, I have a simple python script inspired by the moveit tutorials using moveit_commander.

I'm using:

  • ROS Melodic on Ubuntu 19.10 compiled from source
  • MoveIt compiled from source, branch master
  • Python 2.7
  • boost 1.67.0

It has always worked with no problems until a few days ago when I have probably done a clean build after some updates and it started doing this:

lrinelli@laptop:~$ rosrun test_pkg test_print_state.py __ns:=edo
Traceback (most recent call last):
  File "/home/lrinelli/ws_moveit/src/test_pkg/src/test_print_state.py", line 6, in <module>
    import moveit_commander
  File "/home/lrinelli/ws_moveit/devel/lib/python2.7/dist-packages/moveit_commander/__init__.py", line 35, in <module>
    exec(__fh.read())
  File "<string>", line 2, in <module>
  File "/home/lrinelli/ws_moveit/src/moveit/moveit_commander/src/moveit_commander/roscpp_initializer.py", line 35, in <module>
    from moveit_ros_planning_interface import _moveit_roscpp_initializer
ImportError: /home/lrinelli/ws_moveit/devel/lib/libmoveit_py_bindings_tools.so.1.0.1: undefined symbol: _ZN5boost6python23throw_error_already_setEv
I have already tried rebuilding from scratch ROS, MoveIt and all my packages with no result. After a lot of research I'm quite convinced that the problem might have something to do with eigenPy. Lately I'm trying the versions from github.com/stack-of-tasks, I also tried install the package they provide or build from source but I still get something like this
Errors  << moveit_ros_planning_interface:make /home/lrinelli/ws_moveit/logs/moveit_ros_planning_interface/build.make.000.log /home/lrinelli/ws_moveit/src/moveit/moveit_ros/planning_interface/move_group_interface/src/wrap_python_move_group.cpp:52:10: fatal error: eigenpy/eigenpy.hpp: No such file or directory
   52 | #include <eigenpy/eigenpy.hpp>
      |          ^~~~~~~~~~~~~~~~~~~~~
compilation terminated.
make[2]: *** [move_group_interface/CMakeFiles/moveit_move_group_interface_python.dir/build.make:63: move_group_interface/CMakeFiles/moveit_move_group_interface_python.dir/src/wrap_python_move_group.cpp.o] Error 1
make[1]: *** [CMakeFiles/Makefile2:3137: move_group_interface/CMakeFiles/moveit_move_group_interface_python.dir/all] Error 2
make: *** [Makefile:141: all] Error 2
cd /home/lrinelli/ws_moveit/build/moveit_ros_planning_interface; catkin build --get-env moveit_ros_planning_interface | catkin env -si  /usr/bin/make --jobserver-auth=3,4; cd - ............................................................................... Failed  << moveit_ros_planning_interface:make              [ Exited with code 2 ]
Failed <<< moveit_ros_planning_interface                   [ 10.4 seconds ] 

Update: using catkin install and then catkin build --force-cmake --pre-clean I managed to complete a build. I tried again with catkin config --no-install and catkin build --force-cmake --pre-clean and the build does not complete.

  • Which version of eigenpy should I use to build moveit master from source?
  • From where should I download eigenPy?
  • Is the first error actually related to eigenpy?

Thanks in advance

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by gvdhoorn
close date 2020-01-22 06:43:19.008343

Comments

As this is a clear build issue, I would suggest you post this on the ros-planning/moveit issue tracker.

eigenpy was only recently introduced in MoveIt, so it could be there is something not completely correct.

gvdhoorn gravatar imagegvdhoorn ( 2020-01-22 04:18:16 -0600 )edit

Post on the tracker: ros-planning/moveit#1850.

Closing as a duplicate now as it's been moved to ros-planning/moveit.

gvdhoorn gravatar imagegvdhoorn ( 2020-01-22 06:43:12 -0600 )edit