Ask Your Question
0

catkin_make sees package as plain cmake

asked 2020-01-09 16:27:33 -0600

rklutz gravatar image

updated 2020-01-09 16:28:32 -0600

Hi, I'm trying to build this pacakge, but catkin_make fails saying that it recognizes it as a plain cmake package. I'm having trouble figuring out why it doesn't see it as a catkin package despite having a package.xml file and using the catkin module in the CMakeLists.txt.

I've tried modifying the CMakeLists to make the catkin inclusion REQUIRED, but still no luck.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-01-09 16:42:56 -0600

rklutz gravatar image

The problem was that the package.xml file had exported <build_type>cmake</build_type>.

edit flag offensive delete link more

Comments

I guess this was done because the Catkin dependency is considered optional by the authors of the package (from here):

# optional for ROS build https://github.com/catkin/catkin_tools
find_package(catkin)

the build script later on then checks whether it is actually being built with Catkin present.

Setting the build_type to cmake makes sense in this case.

Can you clarify why you want the build_type to not be cmake?

gvdhoorn gravatar imagegvdhoorn ( 2020-01-10 00:59:05 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2020-01-09 16:27:33 -0600

Seen: 11 times

Last updated: Jan 09