ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Network error when trying to launch a node on an other machine

asked 2019-12-12 07:17:04 -0500

Alrevan gravatar image

updated 2019-12-12 09:25:40 -0500


My distribution is ros-kinetic and I am using ubuntu 16.04 on both machines

I am trying to run a node on a second machine (a realsense camera node) by adding this lines in my launch file:

<machine name="suitee" address="" default="true" />
<include file="$(find s_bringup)/launch/rs_aligned_depth.launch" machine="suitee"/>

I have followed the network setup tutorial here:

Specifically, I have the following variables set on my master machine (where roscore is ran):

export ROS_MASTER_URI=http://${ROS_HOSTNAME}:11311

I have these set on my slave machine:

export ROS_IP=

I also respectively modified the /etc/hosts file on both machines:

For master : suitee

For slave: suitee2

I can ping both machines correctly from each other.

However when I try to run my launch file, I get the following error:

started roslaunch server
remote[] starting roslaunch
remote[]: creating ssh connection to
/usr/lib/python2.7/dist-packages/Crypto/Cipher/ FutureWarning: CTR mode needs counter parameter, not IV
self._cipher =, *args, **kwargs)
remote[]: failed to launch on suitee:

Unable to establish ssh connection to []: Server u'' not found in known_hosts

[] killing on exit
unable to start remote roslaunch child:
The traceback for the exception was written to the log file

I have tried to remove the know_hosts files and connect via ssh and I can connect from both machines using:

ssh suitee@
ssh suitee2@

EDIT: I can correctly see all topics on both machines and I i launch the node manually on the slave card, I can see the published topics correctly and it seems to have no problems to find the master.

Can anyone help me on this ?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2019-12-16 04:48:42 -0500

Alrevan gravatar image

I finally found the answer for this issue:

I had to add the tag "user" into the launch file:

<machine name="suitee" address="" default="true" user="suitee" />
<include file="$(find s_bringup)/launch/rs_aligned_depth.launch" machine="suitee"/>

I also had to follow the answer here:

edit flag offensive delete link more

Question Tools



Asked: 2019-12-12 07:17:04 -0500

Seen: 531 times

Last updated: Dec 16 '19