Ask Your Question
0

Network error when trying to launch a node on an other machine

asked 2019-12-12 07:17:04 -0600

Alrevan gravatar image

updated 2019-12-12 09:25:40 -0600

Hello,

My distribution is ros-kinetic and I am using ubuntu 16.04 on both machines

I am trying to run a node on a second machine (a realsense camera node) by adding this lines in my launch file:

<group>
<machine name="suitee" address="192.168.0.100" default="true" />
<include file="$(find s_bringup)/launch/rs_aligned_depth.launch" machine="suitee"/>
</group>

I have followed the network setup tutorial here: http://wiki.ros.org/ROS/NetworkSetup

Specifically, I have the following variables set on my master machine (where roscore is ran):

export ROS_HOSTNAME=192.168.0.142
export ROS_MASTER_URI=http://${ROS_HOSTNAME}:11311

I have these set on my slave machine:

export ROS_IP=192.168.0.100
export ROS_MASTER_URI=http://192.168.0.142:11311

I also respectively modified the /etc/hosts file on both machines:

For master : 192.168.0.100 suitee

For slave: 192.168.0.142 suitee2

I can ping both machines correctly from each other.

However when I try to run my launch file, I get the following error:

started roslaunch server http://192.168.0.142:42619/
remote[192.168.0.100-0] starting roslaunch
remote[192.168.0.100-0]: creating ssh connection to 192.168.0.100:22
/usr/lib/python2.7/dist-packages/Crypto/Cipher/blockalgo.py:141: FutureWarning: CTR mode needs counter parameter, not IV
self._cipher = factory.new(key, *args, **kwargs)
remote[192.168.0.100-0]: failed to launch on suitee:

Unable to establish ssh connection to [192.168.0.100:22]: Server u'192.168.0.100' not found in known_hosts


[192.168.0.100-0] killing on exit
unable to start remote roslaunch child: 192.168.0.100-0
The traceback for the exception was written to the log file

I have tried to remove the know_hosts files and connect via ssh and I can connect from both machines using:

ssh suitee@192.168.0.100
ssh suitee2@192.168.0.142

EDIT: I can correctly see all topics on both machines and I i launch the node manually on the slave card, I can see the published topics correctly and it seems to have no problems to find the master.

Can anyone help me on this ?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-12-16 04:48:42 -0600

Alrevan gravatar image

I finally found the answer for this issue:

I had to add the tag "user" into the launch file:

<group>
<machine name="suitee" address="192.168.0.100" default="true" user="suitee" />
<include file="$(find s_bringup)/launch/rs_aligned_depth.launch" machine="suitee"/>
</group>

I also had to follow the answer here: https://answers.ros.org/question/4144...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2019-12-12 07:17:04 -0600

Seen: 28 times

Last updated: Dec 16 '19