rqt freezes when opening Dynamic Reconfigure

asked 2019-12-04 04:34:40 -0600

brkk gravatar image

updated 2019-12-04 04:41:46 -0600

Hi,

rqt freezes when we try to open Dynamic Reconfigure plugin (see the screenshot) .I tried it with dashing and eloquent (on Ubuntu 18.04) but the behavior is the same. Also you cannot terminate it with Ctrl+C it gives the following error. I had to kill it manually. I am suspecting there might be a problems on the saved perspectives. I tried to removed all the perspectives and even tried with new installation but it didn't help. Does anybody have an idea how can I use this plugin ?

rqt

^C[INFO] [rclcpp]: signal_handler(signal_value=2)

PluginHandler.save_settings() plugin "rqt_reconfigure/Param#1" raised an exception:

Traceback (most recent call last):

File "/opt/ros/dashing/lib/python3.6/site-packages/qt_gui/plugin_handler.py", line 191, in save_settings self._save_settings(plugin_settings, instance_settings)

File "/opt/ros/dashing/lib/python3.6/site-packages/qt_gui/plugin_handler_direct.py", line 114, in _save_settings self.emit_save_settings_completed()

File "/opt/ros/dashing/lib/python3.6/site-packages/qt_gui/plugin_handler.py", line 207, in emit_save_settings_completed callback(self._instance_id)

File "/opt/ros/dashing/lib/python3.6/site-packages/qt_gui/plugin_manager.py", line 459, in _close_application_save_callback self._close_application_shutdown_plugins()

File "/opt/ros/dashing/lib/python3.6/site-packages/qt_gui/plugin_manager.py", line 467, in _close_application_shutdown_plugins info['instance_id'], self._close_application_shutdown_callback)

File "/opt/ros/dashing/lib/python3.6/site-packages/qt_gui/plugin_manager.py", line 353, in _shutdown_plugin handler.close_signal.disconnect(self.unload_plugin)

TypeError: disconnect() failed between 'close_signal' and 'unload_plugin'

Terminated

image description

edit retag flag offensive close merge delete

Comments

Works for me. Do you have the latest versions installed (ros-dashing-rqt-reconfigure, ros-dashing-qt-gui)? Maybe try rqt --clear-config? Also how is the service caller plugin shown in the screen shot involved?

Dirk Thomas gravatar imageDirk Thomas ( 2019-12-04 11:31:01 -0600 )edit

rqt --clear-config fixed the issue somehow if you use rqt_reconfigure with gazebo it goes to that state again. To reproduce the problem open rqt start Dynamic Reconfigure plugin launch gazebo then click the refresh button on the Dynamic Reconfigure page then it freezes. And service caller plugin is not involved to the problem.

brkk gravatar imagebrkk ( 2019-12-05 01:52:31 -0600 )edit

I also reproduce this in another way. First fire up rqt and start Dynamic Reconfigure plugin. Then fire up a node lets say ros2 run demo_nodes_cpp even_parameters_node then on the plugin page click refresh button so the node is listed on the left column.Then close the even_parameters_node node then click the even_parameters_node on the Dynamic Reconfigure page which freezes the whole rqt.

brkk gravatar imagebrkk ( 2019-12-05 08:27:05 -0600 )edit