Need help with a roslaunch error

asked 2019-11-24 22:48:00 -0600

klondikebarr gravatar image

updated 2019-11-24 23:34:24 -0600

gvdhoorn gravatar image

Straight dump of the error message:

root@klondikebarr:/home/software/custom_ws/src/miniproject2/launch# roslaunch pid.launch
... logging to /root/.ros/log/e5b49bf0-0f29-11ea-85a6-b827ebff05b6/roslaunch-klondikebarr-243.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

Traceback (most recent call last):
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/__init__.py", line 306, in main
    p.start()
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/parent.py", line 268, in start
    self._start_infrastructure()
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/parent.py", line 217, in _start_infrastructure
    self._load_config()
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/parent.py", line 132, in _load_config
    roslaunch_strs=self.roslaunch_strs, verbose=self.verbose)
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/config.py", line 451, in load_config_default
    loader.load(f, config, verbose=verbose)
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/xmlloader.py", line 749, in load
    self._load_launch(launch, ros_config, is_core=core, filename=filename, argv=argv, verbose=verbose)
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/xmlloader.py", line 721, in _load_launch
    self._recurse_load(ros_config, launch.childNodes, self.root_context, None, is_core, verbose)
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/xmlloader.py", line 655, in _recurse_load
    default_machine, is_core, verbose)
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/xmlloader.py", line 685, in _recurse_load
    val = self._include_tag(tag, context, ros_config, default_machine, is_core, verbose)
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/xmlloader.py", line 95, in call
    return f(*args, **kwds)
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/xmlloader.py", line 589, in _include_tag
    inc_filename = self.resolve_args(tag.attributes['file'].value, context)
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/xmlloader.py", line 183, in resolve_args
    return substitution_args.resolve_args(args, context=context.resolve_dict, resolve_anon=self.resolve_anon)
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/substitution_args.py", line 370, in resolve_args
    resolved = _resolve_args(resolved, context, resolve_anon, commands)
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/substitution_args.py", line 383, in _resolve_args
    resolved = commands[command](resolved, a, args, context)
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/substitution_args.py", line 151, in _find
    source_path_to_packages=source_path_to_packages)
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/substitution_args.py", line 197, in _find_executable
    full_path = _get_executable_path(rp.get_path(args[0]), path)
  File "/usr/lib/python2.7/dist-packages/rospkg/rospack.py", line 203, in get_path
    raise ResourceNotFound(name, ros_paths=self._ros_paths)
ResourceNotFound: pid
ROS path [0]=/opt/ros/kinetic/share/ros
ROS path [1]=/home/software/custom_ws/src
ROS path [2]=/home/software/catkin_ws/src
ROS path [3]=/opt/ros/kinetic/share

I have no idea what is wrong. I have a launch file that appears to be unable to be ran. thank you for any help.

edit retag flag offensive close merge delete

Comments

Two comments/questions:

  1. why are you running things as root?
  2. do you have the pid package installed?
gvdhoorn gravatar imagegvdhoorn ( 2019-11-24 23:35:01 -0600 )edit

There seem to be more an more of questions following this pattern: Start with Straight dump of the error or similar with some pasted snippets and little to no context.

See e.g. #q318902, #q320051, #q324528, #q325313, #q336249 and #q330848, to just name a few.

The posts seem to almost exclusively come from users that have just registered, and that don't really provide more information when asked for it (there are some exceptions in the examples, but still...). To me, those seem to be at least in part bots.

Instead of wasting resources on answering those kind of questions and and querying for more information, should we start closing them with a link to the Support page? I'd suggest that, but obviously this is up for discussion...

mgruhler gravatar imagemgruhler ( 2019-11-25 02:20:07 -0600 )edit

Ok so basically this is a program running on a bot called duckiebot. This is for a class assignment we are suppose to write a pid controller. So I wrote the controller and created the ros package on my computer which is running ubuntu 18.04. We used dockerfiles to get everything on our duckiebot and the duckiebot commands put everything into root when ur connected with and running programs on the robot itself.

As for is the thing on the machine. So I can see the file it's trying to launch which is pid.launch in one of the directories. But if I run roslaunch <package_name> <file_name.launch> it cant find the file. If I just roslaunch the file however it seems to launch until it then cant find itself. I apologize if this is really bad information I have little experience with ros and programming in general ...(more)

klondikebarr gravatar imageklondikebarr ( 2019-11-25 02:51:34 -0600 )edit

@klondikebarr thanks for adding additional information and, above all, context. Please put this in your question by editing it, instead of commenting below here, and make sure that all relevant steps are decscribed, together with what you have tried so far and what didn't work. Also, you still haven't answered question 2 by @gvdhoorn above.

mgruhler gravatar imagemgruhler ( 2019-11-25 05:40:39 -0600 )edit