ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Error in loading xacro file [baxter.urdf.xacro]

asked 2019-11-04 01:19:02 -0500

Hanbit.OH gravatar image


  • Ubuntu 16.04
  • Ros Kinetic
  • xacro 1.11.3

I am trying to simulate Baxter on Gazebo, I used the following instructions for the installation:
baxter simulation

But after typing the command:

roslaunch baxter_gazebo baxter_world.launch

it gives me this error:

Invalid <param> tag: Cannot load command parameter [robot_description]: command [/opt/ros/kinetic/lib/xacro/xacro -i /home/baxter3/catkin_ws/src/baxter_common/baxter_description/urdf/baxter.urdf.xacro gazebo:=true left_electric_gripper:=true right_electric_gripper:=true] returned with code [2].

Param xml is <param command="$(find xacro)/xacro -i $(find baxter_description)/urdf/baxter.urdf.xacro gazebo:=true left_electric_gripper:=$(arg left_electric_gripper) right_electric_gripper:=$(arg right_electric_gripper)" if="$(arg load_robot_description)" name="robot_description"/> The traceback for the exception was written to the log file

I tried to solve this problem with :

but anything can't solve my problem.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2020-07-15 14:35:20 -0500

Ankita gravatar image

Check whether your xml file is well formed or not.

These error are most probable in this case.

Verify your xml files via xml validators online. I have solved my problem through that only.

edit flag offensive delete link more

answered 2019-11-05 19:29:36 -0500

Hanbit.OH gravatar image

I purge ros, gazebo and try to re-install by :

And my problem is solved but I don't know what is the reason.

edit flag offensive delete link more

Question Tools



Asked: 2019-11-04 01:19:02 -0500

Seen: 409 times

Last updated: Nov 05 '19