Ask Your Question
0

Problems installing the "create_autonomy" package on ubuntu 14.04

asked 2019-10-26 18:49:39 -0600

updated 2019-10-27 05:27:56 -0600

gvdhoorn gravatar image

Im trying to install the package create_autonomy for control the Roomba 645 series, but i have a problem when i need to install this dependencies:

$ cd ~/create_ws
$ rosdep update
$ rosdep install --from-paths src -i

when i going to install --from-paths src -i this error appears:

ERROR: the following packages/stacks could not have their rosdep keys resolved to system dependencies:
ca_driver: Cannot locate rosdep definition for [libcreate]
ca_tools: Cannot locate rosdep definition for [joy_teleop]

So what can i do i need to finish my project.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-10-27 05:30:52 -0600

gvdhoorn gravatar image

updated 2019-10-27 06:04:32 -0600

Do you have a specific reason for wanting to setup a Trusty+Indigo system?

It would seem create_autonomy is compatible with at least Kinetic (according to the wiki page.

Also: when asking these kinds of questions always mention for which platform you are trying to build. What is the output of lsb_release -a and uname -rvmp?

Reason I ask is that it's likely that rosdep update is skipping Indigo, as it's an EOL distribution. That leads to an empty database, which leads rosdep to not be able to resolve anything on that OS. You'll have to add --include-eol-distros to the rosdep update command line for Trusty+Indigo.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-10-26 18:49:39 -0600

Seen: 41 times

Last updated: Oct 27