ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
0

RLexception: Sick_tim551_2050001 is neither a launch file error.

asked 2019-10-19 14:20:04 -0500

Nagarjun gravatar image

updated 2019-10-20 11:54:23 -0500

jayess gravatar image

Hello,

At first, I cloned sicktim files in kinetic version in my laptop(using ubuntu 16.0.4) from github and changed some parameters in those files according to my lidar. I am using TIM561-2050101S01 lidar. Later, I realized I need to use PC in lab to work with Lidar for long term, I cloned again in melodic version (as my PC is using ROS melodic) and replaced the files with kinetic files that I have changed according to my Lidar configuration.

My catkin_make is successful. But when I use:

roslaunch sick_tim sick_tim551_2050001.launch model:=urdf/sick_tim.urdf.xacro

to launch the urdf file I am getting the following error:

RLException: [sick_tim551_2050001.launch] is neither a launch file in package [sick_tim] nor is [sick_tim] a launch file name
The traceback for the exception was written to the log file

I also removed model in launch command above, but same error persists.

I also used:

roslaunch sick_tim sick_tim551_2050001.launch

same error exists

I also did this:

roslaunch sick_tim sick_tim551_2050001.launch:='$(find sick_tim)/urdf/sick_tim.urdf.xacro'

the error:

RLException: [sick_tim] is not a launch file name
The traceback for the exception was written to the log file

Even, though I am able to find the sick_tim launch file in my PC. I am unable to launch it.

Can anyone answer this question? What is this error means? What should I do to remove this error?

I also tried sourcing the files.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2019-10-20 09:41:47 -0500

fergs gravatar image

Did you source the setup.bash for your workspace? For instance if your workspace is "~/melodic" did you run "source ~/melodic/devel/setup.bash"?

A quick check would also be, can you "roscd sick_tim"? If not, the package you built is still not on your ROS_PACKAGE_PATH (in which case, you probably haven't sourced the workspace yet).

edit flag offensive delete link more
0

answered 2023-05-10 21:50:17 -0500

Did you configure the ip address of TIM561 and port in the launch file? And also the local ipv4 address in computer settings.If they donnot work ,I guess the ip address of lidar is wrong,you can configure it in software.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2019-10-19 14:20:04 -0500

Seen: 911 times

Last updated: Oct 20 '19