Eigen3 issue in ROS

asked 2019-10-18 04:33:55 -0600

RuiAidrivers gravatar image

updated 2019-10-18 04:48:43 -0600

gvdhoorn gravatar image

Hi there,

I've met some strange issues with eigen3 in ROS when I'm making the autoware. I've installed the eigen3 in /usr/include/ as the ROS requests. And I've cp the Eigen folder in /usr/include/ as the installation guide did.

But my make file still has some strange issues like below:

/usr/include/eigen3/Eigen/src/Core/arch/SSE/PacketMath.h:60:39: error: ignoring attributes on template argument ‘__m128 {aka __vector(4) float}’ [-Werror=ignored-attributes]
 template<> struct is_arithmetic<__m128>  { enum { value = true }; };
                                       ^
/usr/include/eigen3/Eigen/src/Core/arch/SSE/PacketMath.h:61:40: error: ignoring attributes on template argument ‘__m128i {aka __vector(2) long long int}’ [-Werror=ignored-attributes]
 template<> struct is_arithmetic<__m128i> { enum { value = true }; };
                                        ^
/usr/include/eigen3/Eigen/src/Core/arch/SSE/PacketMath.h:62:40: error: ignoring attributes on template argument ‘__m128d {aka __vector(2) double}’ [-Werror=ignored-attributes]
 template<> struct is_arithmetic<__m128d> { enum { value = true }; };
                                        ^
/usr/include/eigen3/Eigen/src/Core/arch/SSE/PacketMath.h:160:43: error: ignoring attributes on template argument ‘Eigen::internal::Packet4f {aka __vector(4) float}’ [-Werror=ignored-attributes]
 template<> struct unpacket_traits<Packet4f> { typedef float  type; enum {size=4, alignment=Aligned16}; typedef Packet4f half; };

I've searched a lot, but didn't find anyone has the same issue. So I hope I could get some help here.

Many thanks!

edit retag flag offensive close merge delete

Comments

Two observations:

as the ROS requests

you mention you're attempting to use Autoware. Please be aware that Autoware != ROS. Autoware uses ROS, but these two are not identical.

I also don't believe the regular installation tutorials of ROS (ie: the Kinetic, Melodic or other installation tutorials) ask you to install Eigen from source in /usr/include. It could be that Autoware wants you to do that though, I don't know.

Second: please link to all tutorials, pages, guides, etc that you are using or referring to in your question. We cannot know what you read somewhere without knowing which pages you've been reading, or which guides you've been following.

gvdhoorn gravatar imagegvdhoorn ( 2019-10-18 04:47:33 -0600 )edit

Also: please tag your questions with the relevant tags. The fact you're using Autoware is very important, as it completely changes certain things.

I've added the autoware tag to your question, but please keep it in mind for the future.

gvdhoorn gravatar imagegvdhoorn ( 2019-10-18 04:48:21 -0600 )edit

You need to provide the full compiler output. Just these few errors is not enough to understand the error. Please also indicate what version of Autoware you are using, how you installed it, etc. Please follow the support guidelines.

Geoff gravatar imageGeoff ( 2019-10-25 01:14:01 -0600 )edit